Using GB=en dictionary segfaults firefox

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Nick Warne, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=417179, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080312 BonEcho/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080312 BonEcho/2.0.0.12

I found sometimes certain sites segfault firefox.  I was running pre-built 2.0.0.12, so reverted my CVS tree to TAG 2.0.0.12 and built from source.  The crash still happens.

I finally traced it to the GB-en dictionary, and can reproduce this 100% on youtube.  If I have this as default spelling language (with or without 'check spelling as I type' on) then EVERYTIME I search at youtube, as soon as I hit the search button, firefox crashes.  If I select default US-en dictionary, the crash doesn't happen.

It also happens sometimes on other sites, but using youtube search produces the segfault everytime.

As stating, using US-en dictionary Firefox is stable.

Nick

Reproducible: Always

Steps to Reproduce:
1.  Install and change spelling Language to GB-en
2.  Search at youtube

Actual Results:  
Crashes immediately after hitting 'search' button

Expected Results:  
No crash
(Reporter)

Updated

10 years ago
Severity: critical → major
(Reporter)

Comment 1

10 years ago
OK, further investigation reveals that if I also change the preferences->advanced->general | language 'preferred language to display pages' to  UK [en-gb] (removed English [en] ) and then use the en-GB dictionary, the crash doesn't happen.

Comment 2

8 years ago
Hi Nick, where are you getting this GB-en dictionary from? I can't see it in my version of Firefox!
(Reporter)

Comment 3

8 years ago
Chris,

I got it from the language add-ons page.  BTW, this bug is so old now, and I am not on line much anymore, I don't know if it is still relevant.

Nick

Comment 4

8 years ago
I tried this with the en-gb pack and couldn't get it to crash.

Updated

7 years ago
Version: unspecified → 2.0 Branch
Closing this based on comment 4, there shouldn't be any issues now with newer Firefox builds. Re-open if still occurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=417179
You need to log in before you can comment on or make changes to this bug.