text-decoration:line-through ignored on <description>

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: gaubugzilla, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

271 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

11 years ago
Created attachment 309135 [details]
Testcase

See testcase - I set the style text-decoration:line-through on a <description> element and it doesn't do anything in the current nightlies. In Firefox 2.0.0.12 however it displays a line in the middle of the text correctly.
(Reporter)

Updated

11 years ago
Blocks: 393966
(Reporter)

Comment 1

11 years ago
Work-around is using <html:div> instead of <description> - but that should not be the permanent solution.

Comment 2

11 years ago
Need to find a regression range here
OS: Windows XP → All
In the case of this particular regression (at least; in 1.6, this works for value= but not for child text nodes, so that's not a regression as I see it) this will probably be fixed when XUL text is rewritten to use nsTextFrameThebes so that it can pick up on other decorations such as text-shadow.

As for workarounds, my preferred workaround is <description><html:span style="
This seems to be fixed on Mozilla/5.0 (X11; U; Linux i686; et; rv:1.9.3a5pre) Gecko/20100507 Minefield/3.7a5pre. Both value= and child text node display line-through.
(Reporter)

Comment 5

9 years ago
I can still see this issue in Firefox 3.0 but it has been fixed in Firefox 3.5 apparently - works for me then.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.