"Mail is not currently available" dialog pauses JPEG loading

RESOLVED DUPLICATE of bug 123440

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 123440
10 years ago
10 years ago

People

(Reporter: Fernando Cassia, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 SeaMonkey/1.1.8

I have an account at Netscape.net IMAP (formerly Netscape Webmail, then converted to AIM mail, servers mail.aim.com and/or imap.aim.com). These are IMAP4 accounts.

For some reason, SeaMonkey mail complains endlessly about "Mail (nn) is not currently available". I haven't the slightest idea of what email it's referring about (if so I'd just delete it so it stops complaining every few mins).

But that's besides the point. The point is that these dialogs BLOCK (stall) the browser. In other words, if you're just loading a large JPEG in the browser when this dialog comes up (it's a new XUL window, like the "find" -CtrlF- dialog is) the download pauses, until you dismiss it by clicking OK.

I don't know about you, but I think these information dialogs (which only have "OK" as a button) should not block whatever the browser is currently doing.


Reproducible: Always

Steps to Reproduce:
1. Have an IMAP account that gives a dreaded "Mail is not currently available" dialog every few mins
2. Attempt to load www.webserver.com/somedir/someimage.jpg (large jpeg)
3. If you get the dialog from point#1, you will see image loading is stopped until you dismiss dialog #1
Actual Results:  
Browser pauses until you dismiss the dialog

Expected Results:  
Browser continues working, regardless of dialog.
Can you reproduce with SeaMonkey v1.1.9 ?

(I guess this is a more general issue about _modal_ dialogs.)
Version: unspecified → SeaMonkey 1.1 Branch

Comment 2

10 years ago
Ya, the dialog shouldn't be shown at all
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
You need to log in before you can comment on or make changes to this bug.