[RFE] show whether page meets declared dtd (was: Want "html quality" indicator in the UI)

VERIFIED DUPLICATE of bug 47108

Status

P3
enhancement
VERIFIED DUPLICATE of bug 47108
18 years ago
14 years ago

People

(Reporter: akkzilla, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Viewer, I'm told, used to have an icon at the bottom that showed red if the page
had bad html, green if it was good html.  

We've had several cases now of pages rendering incorrectly because they
specified a DTD to which they did not actually adhere.  But from the user's
point of view, what happens is that the page doesn't lay out correctly in
mozilla though it does in every other browser, and there's no clue as to why.

It would be *really* helpful if we could get some space, perhaps next to the
status bar, where we could put a small icon which would turn red if we saw bad
html; better yet, somewhere where the user could click on the red icon and get
something like a view source window popping up highlighting the bad html (Rick
says this capability is already partially implemented, though not yet ready for
prime time).

If we can't get a red/nonred icon, then we should at least do something like
change the status bar to say that we saw bad html -- something that will give
the user a clue that there's a problem.

Comment 1

18 years ago
A red/green light would really clash with the default blue chrome. 'Document:
Done' needs to be changed anyway, maybe:

Done.   /   Done, but with errors.

would suffice. But then there is no place to determine what type of errors. What
about a 'Compliance' tab in the page info dialog? I'd really like to see
mozilla's syntax checking as good as w3c's validator. Would really make it of
such a great use to developers, and emphasize mozilla's compliance as a
renderer.

Comment 2

18 years ago
the "document done (with errors) is better, but what if there is javascript on
the page that alters the status?  How about doing this on the progress bar? 100%
(with errors).  

Comment 3

18 years ago
I don't know if Mozilla provides any code yet to get the information needed for 
a "Compliance Tab", but until it does the simplest would be something clickable 
which indicates there are problems with the page and on clicking passes the page 
to http://validator.w3.org/. The results can of course be fed into the sidebar.

Perhaps the progress bar? Give it a tooltip and perhaps an orange/red border?

Comment 4

18 years ago
I like detecting bad HTML, but see bugid 6211.
off my bug list
Assignee: ben → nobody
Keywords: helpwanted
"Document done (with errors)" may be misunderstood. (Did Mozilla err?) It would be 

better to say the document was in error: eg. "Bad HTML", "The Document contained 

errors.", "Erroneous document".
Target Milestone: --- → Future

Comment 7

18 years ago
Mozilla gets a lots of crap because it doesn't handle erroneous pages exactly 
like other browsers so this would _the_ way to direct people's aggresion away 
from Mozilla (and Netscape 6) to the page authors. Sure, some would still blame 
Mozilla, but people would soon learn to look for the visual cue that tells you 
that the page was badly written when it doesn't look right.

I recommend this for nsbeta3 to save Nestcape's as. If there is no visual 
indicator that the page contains errors, all blame will hit Netscape and there 
are already many complaining even though the browser isn't yet well spread.

(I also think page authors would like it. Many aren't even aware that their code 
isn't perfect)

For the actual UI, I like a green and red blob with informative tooltips in the 
status bar best.
Keywords: nsbeta3

Comment 8

18 years ago
changing to rfe and making summary more clear.  

what do we do in the case where the page doesn't declare a dtd?  compare 
against 4.01 transitional?


my opinion is that bug 6211 would be very useful, but this bug by itself 
wouldn't help much.  besides, it would be hard to debug this feature without 
being able to see why mozilla thinks a page is bogus.

perhaps we could do this and dump errors to the console window for now.  when 
users click on the indicator, they will be told that error reporting is a 
developing feature and they have to start mozilla with a console (mozilla.exe -
console) if they want to see the errors.  that should be enough to allow this 
feature to be debugged.

sending users to validator.w3.org (as disttsc@bart.nl suggested) would be an 
alternative partial solution, but it wouldn't let mozilla say why it handles 
something the way it does, or give hints such as "most of the time extra 
</script> tags are encountered, the cause is trying to include '</script>' in a 
string within a <script> without escaping it as '<\/script>'."
Severity: normal → enhancement
Summary: Want "html quality" indicator in the UI → [RFE] show whether page meets declared dtd (was: Want "html quality" indicator in the UI)

Comment 9

18 years ago
I agree with Daniel Bratell.

Do we have the info, that the page is bogus, somewhere easily accessible? If
yes, a basic implementation (some hint in the status bar plus a link to
validator.w3.org) would be very easy, not?
Would the parser component helo this?

Comment 11

18 years ago
Comments from an NG post by me in which I proposed a UI for this sort of
thing... My proposed UI involves a modal dialog (with a "don't show me this
again [for this site]" but another way would be a statusbar indication and
sidebar panel. The most important aspects of my proposal are:

* The errors are available behind a "Details>>" button
* The user has the option to choose quirks or strict mode - in other words, if a
page breaks its own DTD, the user can tell Moz to ignore the DTD and act as if
the page didn't specify one.
* It would only apply for pages where the Strict parsing mode would be triggered
(HTML >4.01 Strict or any XHTML?)

My full proposal including suggested message text is at
news://news.mozilla.org/399AF13A.863EEB8C%40netreach.net
Stuart Ballard - whould you write this?

Comment 13

18 years ago
Marking nsbeta3- per pdt review
Whiteboard: [nsbeta3-]

Comment 14

18 years ago
iCab for MacOS uses a smiling/frowning face to indicate good/bad HTML. There's
also a very usefull error report available, if errors are found on the page.

Find more info on <http://www.icab.de/smile.html>

Michael

Comment 15

17 years ago

*** This bug has been marked as a duplicate of 47108 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.