File input field cannot be modified or cleared

RESOLVED DUPLICATE of bug 431098

Status

()

RESOLVED DUPLICATE of bug 431098
11 years ago
11 years ago

People

(Reporter: gnac.o.matic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

After submitting a file upload to an imageboard, I received their "duplicate file entry" error, so I clicked back and attempted to clear the file upload field, which was not possible, even when successfully highlighting the text without causing the file upload dialogue to appear.

Refreshing the page did not clear the field, and I had to reopen the page from the referring link.

While this bug was first discovered on an imageboard site, it can be replicated anywhere there is a file upload field.

Reproducible: Always

Steps to Reproduce:
1. Select any file to fill the file input field
2. Attempt to select all text in the field
3. Use backspace / delete or try to modify the text to no avail
Actual Results:  
File upload field appears to be "locked". It cannot be modified directly; only by the file upload dialogue.

Expected Results:  
Preferably not cause the file upload dialogue to appear, and allow the user to modify / clear the contents of the field.

Comment 1

11 years ago
I, too, have been bitten by this; it is extremely frustrating from a usability standpoint, as I often want to simply clear or hand-modify a file.  I'm wondering if this was done for security's sake, as an editable field may be able to be modified from a script more easily (and thus have some known critical file be placed in the form).  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 431098
You need to log in before you can comment on or make changes to this bug.