schema names messed up for phone fields at eBay.com

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
not sure how this might be related to bug 42299 (if at all), but i noticed that
when form data is captured at the eBay Change Registration Info form, the schema
for the primary phone, secondary phone and fax number are in an incorrect
format. ie, they look like "cgi4.ebay.com/..." which they shouldn't. the schema
names for the other fields look sensible, however.

Comment 1

19 years ago
I have several comments and questions on this bug report:

1. When I attempt to get to the ebay registration page (www.ebay.com, then click 
on register), I get to the site mentioned in the URL of this report and it lays 
out (well, sort of -- the ebay logo doesn't display).  But I immediately get a 
box that pops up saying "The connection was refusted when attempting to contact 
cgi4.ebay.com."  (If I try this using 4.x, I don't have this problem.)  How come 
Sarah didn't have this problem?

2. If I ignore the problem in 1 and dismiss the pop-up box, I can then select 
the country and press continue.  That takes me to a second page which says:

 Input Error
   We did not successfully receive all the required information from the page.
   Please go back and ensure that all fields are filled in.

So I am unable to get to the registration page and therefore am unable to 
reproduce this problem.

3. Since I can get to the page from 4.x, I can make some observations.  For one 
thing, there is no mention of a fax number on this page so I don't understand 
how any schema for a fax number could possibly get captured (report above says 
fax number was captured "in an incorrect format").  It's true that ebay used to 
ask for the fax number at one time (see the ebay page in the wallet samples) but 
it appears that they have dropped that from their registration page.

4. As it turns out, all fields on the ebay form with the exception of phone 
numbers use very generic field names -- i.e., "name", "company", "address", 
"city", "state", and "zip".  So wallet will be able to recognize these and 
determine the appropriate schema without any url-specific information for ebay.  
The phone number fields, however, would not be recognized unless the 
url-specific tables are accessed.  So from the symptoms I would have to conclude 
the the url-specific tables for e-bay were not being accessed.

5. I indeed have support for the ebay page in the URL-specific tables so I am 
surprised that they are not being accessed.  But until figure out how to get 
past problems 1 and 2, I am unable to debug this.
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 2

19 years ago
OK, I solved problems 1 and 2.  Seems that cartman is required even though I'm 
not using ssl or https.  I just filed bug 42365 on that.  So now I'll 
investigate further on this bug.

Comment 3

19 years ago
I spoke too soon.  Installing cartman corrected problem 1.  It did *not* correct 
problem 2.
(Reporter)

Comment 4

19 years ago
steve, if it helps any, i went to the change registration info page via the
"regular connection," not the secure connection. ie, at
http://pages.ebay.com/services/myebay/change-registration.html i clicked the
Submit button under Regular Connection (the choice on the left side of the
table). (i don't know if you got as far as this page, tho'.)

Comment 5

19 years ago
Problem 2 mentioned above has been broken out and put into bug 42368.

Comment 6

19 years ago
I now understand that Sarah was using the ebay change-registration form instead 
of the new-registration form.  Interestingly, the change-registration form asks 
for fax number whereas the new-registration form does not.

So I tried Sarah's test and did not observe a problem with the primary or 
secondary phone numbers -- they is being stored with the correct schema name 
(home.phone and home.altphone).  The ever-changing wallet tables must have 
corrected this problem.

But the fax number is indeed being stored with a localized schema name 
(cgi4.ebay.com/aw-cgi/...) just as Sarah said.  Reason is that I never added a 
fax number schema in the ebay url-specific mapping table because I never saw 
such a field on their registration form.  But it's easy for me to add an entry 
into the ebay table for faxnumber and I will do so right now.

Comment 7

19 years ago
OK, table has been updated so I'm closing out this report.  But, strictly 
speaking, this wasn't a bug -- it was just that wallet didn't recognize the 
field name on the ebay form.  Wallet can never recognize every field name on 
every form but we hope to get most of them.  And we can keep adding more field 
names to support more and more forms in the future by simply updating the 
server-based tables (no need to redistribute or update the browser).

One more comment.  The fieldname used on the ebay form for the fax number was 
"faxphone".  That was pretty general so I added it to the generic 
field-to-schema mapping table instead of the ebay-specific table.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
vrfy, for the case of adding the fax number field. looks good.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
Target Milestone: M17 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.