Closed Bug 423003 Opened 12 years ago Closed 11 years ago

drop arrow only appears at the end of tabs when dragging a link, should appear between tabs when dragging link between tabs

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 320638

People

(Reporter: callea.gaetano.andrea, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Hi, the drop arrow only appears at the end of tabs when dragging a link, should appear between tabs when dragging link between tabs.

This "link drag and drop between tabs" thing it's a new feature of ff3 that i've suggested in ff brainstorm back in 2006 and it has been now fully implemented and it works as it should except for one thing: feedback. 

As is now, when you drag the link, the link is not resized and you have (at least) a word or (at worse) a whole prhase floating under your mouse, resulting pretty uncomfortable. Beside that, the feedback that this feature gives as is now, it looks like it's going to replace the tab.

For consinstency and beauty matters it should draw an arrow pointing downwards and spacing apart the tabs a bit, instead of the dragged text. I mean the same arrow that appears already when you drag the link at the end (the far right) of the tabs. 

I hope i've been clear enough; else you can try dragging a link: 

0) on an existing tab to replace it and look at the kind of feedback it gives.
1) to the end of the existing tabs and see the arrow.
2) between some existing tabs and realize that we need an arrow and a bit of spacing there between the tabs.
3) move a tab to change its position and see that arrow as i mean it.

I'm at your disposal for any further explanation.
thanks for firefox 3, it rocks. =)

Reproducible: Always

Steps to Reproduce:
improvement of a feature. can't reproduce it. but you should try the dragging this for yourself as explained in the above details.
Actual Results:  
the feedback now looks like drag&drop between tabs it's going to replace a tab.

Expected Results:  
we should have a different feedback with an arrow and a bit of spacing between tabs.

as of ff3b4 on linux, but is the same for all OSes.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320638
You need to log in before you can comment on or make changes to this bug.