Firefox 3.0b4 doesn't show images displayed via javascript

RESOLVED DUPLICATE of bug 411831

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 411831
10 years ago
10 years ago

People

(Reporter: Greg Norris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Arkel uses javascript to display a series of revolving snapshots of items for sale.  These images aren't visible when using Firefox 3.0b4, but display fine under 2.0.0.12.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 3.0b4 using the "-safe-mode" option.
2. Browse to the provided URL

Actual Results:  
No images are displayed above the "add to cart" image.

Expected Results:  
A periodically changing image of the relevant product should be visible.

I'm not particularly javascript-saavy, so it's certainly possible this is caused by a website bug.  The fact that it displays fine using Firefox 2.0.0.12 makes me suspect otherwise, however.
(Reporter)

Comment 1

10 years ago
Created attachment 309578 [details]
screenshot from Firefox 3.0b4
(Reporter)

Comment 2

10 years ago
Created attachment 309580 [details]
screenshot from Firefox 2.0.0.12
(Reporter)

Comment 3

10 years ago
Created attachment 309581 [details]
screenshot from Firefox 3.0b4

I'm having problems displaying the original PNG screenshot, so here's a JPG version
Attachment #309578 - Attachment is obsolete: true
(Reporter)

Comment 4

10 years ago
Created attachment 309582 [details]
screenshot from Firefox 2.0.0.12

I'm having problems displaying the original PNG screenshot, so here's a JPG version
Attachment #309580 - Attachment is obsolete: true
wfm with SM trunk and Firefox 3b4 on win32

Comment 6

10 years ago
WFM, Firefox 3.0b4 and trunk 2008030904 on Linux.

Greg, can you see the image when using the image URL?
http://www.arkel-od.com/panniers/commuter/images/commuter_front.gif
(Reporter)

Comment 7

10 years ago
That's weird... it's blank when I follow the link initially, but displays OK the first time I do a reload.  Following any subsequent reloads, however, it's missing again.

The latest nightly yielded the exact same behavior.
(Reporter)

Comment 8

10 years ago
I get the same behaviour with Firefox 3.0b5, but couldn't reproduce it using the portable release under WinXP.  At this point I'm assuming that it's either a Linux-specific issue, or a subtle incompatibility with the shared libraries on my system.
looks like this is a dupe of bug 411831
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411831
(Reporter)

Comment 10

10 years ago
Yes, bug 411831 seems to fit the pattern I'm seeing. Thanx!
You need to log in before you can comment on or make changes to this bug.