YouTube player not visible

RESOLVED FIXED in mozilla1.9beta5

Status

()

defect
P1
normal
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: firefox.bugzilla, Assigned: sicking)

Tracking

({regression})

Trunk
mozilla1.9beta5
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre

In the latest nightly (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre) the YouTube player disappears when trying to play a video.

Reproducible: Always

Steps to Reproduce:
1.Go to youtube.com and try to play a video.
Actual Results:  
The video player appears for a fraction of a second but then disappears.

Expected Results:  
Player should remain visible and play video.
Does it work with a new profile?
- http://kb.mozillazine.org/Profile_manager

What version of Flash do you have installed (about:plugins), and also, have you ever had FlashBlock installed?
Yes, it does work with a clean profile!
Flash version: Shockwave Flash 9.0 r115

I have never had FlashBlock installed. I do have AdBlock Plus, but it claimed to block 0 elements on the page. The only other add-on I have is Forecastfox.
Version: unspecified → Trunk
After some research it seems that it is AdBlock Plus that is causing the problem. I tried disabling it and it worked. This has never been a problem before though.
Is there any chance you can find a regression using the hourly archive?
- http://hourly-archive.localgho.st/
This certainly sounds like a change in behaviour, and it'd probably be useful to know what bug caused it.
20080314_1557: Works, 20080314_1734: Doesn't work

The only checkin that seems to have anything to do with addons is bug 396129...

Petter thanks for the range!

Checkins to module PhoenixTinderbox between 2008-03-14 15:57 and 2008-03-14 17:33 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1205535420&maxdate=1205541239
Keywords: regression
These errors show up in Error Console:

Security Error: Content at http://s.ytimg.com/yt/js/base_all_with_bidi-vfl34929.js may not load data from http://youtube.com/watch?v=xtAja20kTCA.

Error: p.GetVariable is not a function
Source File: http://s.ytimg.com/yt/js/base_all_with_bidi-vfl34929.js
Line: 3286 
Bug 401155 sounds much more likely as the trigger for this issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Flash video handling is seriously broken with these recent builds.  I'm sharing my findings, because the Adblock Plus and Flashblock effects appears to be flukes - especially with today's build.  I am unable to find any consistency whatsoever.  Here are my findings for three different profiles:

Profile 1
---------
Phase 1: Adblock Plus + Flashblock: msnbc video failed, abcnews video failed
Phase 2: safemode: abcnews video successful, msnbc video not tested
Phase 3: only Adblock Plus: msnbc video failed, abcnews video successful
Phase 4: only Flashblock: msnbc video successful, abcnews video failed
Phase 5: neither Flashblock nor Adblock Plus: both msnbc and abcnews video fail
Phase 6: all extensions disabled: both msnbc and abcnews video fail
Phase 7: safemode: both msnbc and abcnews video fail
Phase 8: all extension enabled: all flash video fails -- even though non-video flash animation works.

Profile 2
---------
This is a simple profile created about a week ago.  It has Adblock Plus and NoScript.  I have made no extension changes to this profile since about 2 or 3 days ago.  RESULT: both msnbc and abcnews video successful

Profile 3
---------
New profile.  Nothing added, nothing changed:  both msnbc and abcnews video FAIL

CONCLUSION
----------
As evident from my experience detailed above, this cannot be an extension issue.  The results make no sense.  There must be something checked into the trunk that caused this.  My first encounter with this issue was with the March 14 build.

It's telling that on the Mozillazine March 16 Trunk build discussion thread, some are reporting that disabling Adblock Plus makes their video work, while others are reporting that installing Adblock Plus makes their video work.  Thus, this has to be a Firefox bug. 
bug 422926 seems to be related
I have found out that for me the videos are not shown when I use adblock with the option NOT to show the TAB for blocking flash or java elements.I can only watch flash videos when I set the option to show those tabs or when Adblock Plus is completely Disabled via the Add-on manager. 

With a clean profile there is no problem and with Adblock disabled there is no problem, too. So for what I see here, I would say this a Adblock Plus related problem. 

I tried to play the videos from msnbc and they are working with Adblock enabled here. 
Wladimir: Is this a bug in your code or rather a regression from bug 401155?
Bug 401155 is probably the reason. The option mentioned in comment 11 will insert a DOM node before the Flash tag - but it will do so on a timeout and not in the content policies call. This is supposed to be valid behavior (but is known to have caused issues on Mac before, I just didn't have a chance to investigate it).
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
I just tested this and options have no influence on this. The issue already occurs if some content policy written in JavaScript exists (tested with an empty content policy). Given the range, definitely result of bug 401155.
Depends on: 401155
Blocks: 401155
No longer depends on: 401155
Hmm. Flashblock doesn't use content policies but the regression range is similar (somewhere between the 14th and 15th - I don't have any hourly builds to test with).
We do remove and insert <object> dom nodes from/into the DOM though and use js scripting methods to stop and start flash objects. Would bug 401155 affect this?
Yes, bug 401155 is very likely the issue here as I redid when we initialize plugins under certain conditions.

It'd be great if someone could provide a minimal testcase.
I do believe i'm having this same issue or a similar issue on Linux. I can't
pull a regression range though...For me, embedded videos (such as the video at:
http://daily.mahalo.com ) don't show up when i have AdBlock Plus on, but they
do show up as soon as i turn it off (and no, i didn't select to block them).
Also, i have no other extensions installed that could possibly be causing this
issue (All i have installed other than ABP and ABP Element Hiding Helper is
Fission and Better Gmail).

Also, my flash version is 9.0 r115
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Assignee: nobody → jonas
I'm having trouble reproducing this. For the people that can: Do you have any extensions installed? What configurations are you using for these extensions?
1) Create a new profile
2) Install Adblock Plus http://adblockplus.org/en/installation (If https://addons.mozilla.org/ is down install 'American English (en-US)' build)
3) Restart Firefox
4) Don't Subscribe to any Adblock plus filter (Hit Cancel)
5) From Adblock Plus 'Options' unselect 'Show tabs on Flash and Java'
6) Load http://www.youtube.com/watch?v=auhHl5-6VdY

The Video doesn't show up.

Just to clear up:
* no adblock plus - youtube works for some, fails for others
* adblock plus with "show tabs" checked - youtube always works
* adblock plus with "show tabs" unchecked - youtube always fails

As a result, some people installed adblock plus only to move from first group to second :)
This minimal content policy is enough for me to reproduce this bug, don't need all of Adblock Plus. Put it into firefox/components directory, create an .autoreg file in your profile and restart.
Thanks! That should be enough to allow me to reproduce. Really appreciate it.
Target Milestone: --- → mozilla1.9beta5
The checkin for Bug 422926 appears to have resolved this.  I can confirm that all my flash video now works with the latest hourly build.
Petter: fixed for you on nightlies?
I'll be able to test this myself tomorrow when the nightlies hit.
Turns out that, while sites like youtube, msnbc, and abcnews now work after the Bug 422926 checkin, CNN video does not work -- even with a new profile and the browser useragent changed to something that CNN accepts.
(In reply to comment #25)
> Petter: fixed for you on nightlies?
> 
I'm away over easter, so I won't be able to test this until monday. Hopefully someone else can test it.
Problem is indeed gone in 2008031905 nightly.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #27)
> Turns out that, while sites like youtube, msnbc, and abcnews now work after the
> Bug 422926 checkin, CNN video does not work -- even with a new profile and the
> browser useragent changed to something that CNN accepts.
> 

I too am having issues with embedded vids on www.cnn.com not loading the page.  Go to any video (live video works), and new pages comes up with a Flash player, and then ends - stays stuck 'Loading'... 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032001 Minefield/3.0b5pre Firefox/3.0 Firefox/2.0.0.12 ID:2008032001

Sorry, I resolved that bug too soon. With 2008031905 nightly the videos on YouTube still don't show up with content policies - only the "Show tabs on Flash and Java" option of Adblock Plus makes them appear (forces a reflow I guess). Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre

adblockplus-0.7.5.3+.2008032018debug.xpi
Yes, works in 2008032005 for me as well, I probably tested too early.
(In reply to comment #30)
> I too am having issues with embedded vids on www.cnn.com not loading the page. 
> Go to any video (live video works), and new pages comes up with a Flash player,
> and then ends - stays stuck 'Loading'... 

See bug 424093 for that issue - seemed related, turned out to be about DOM Storage, though :)

Marking this as fixed by 422926.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Depends on: 422926
Resolution: --- → FIXED
Actually, this was probably fixed by bug 422926.
You need to log in before you can comment on or make changes to this bug.