Firefox leaks nsGlobalWindows when i close Firefox with the Places Library open

VERIFIED FIXED

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({mlk})

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 309695 [details]
leak log 

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5pre) Gecko/2008031413 Minefield/3.0b5pre ID:2008031413 (on Fedora F8)

Steps to reproduce:
- Open the Places Library
- Close Firefox with the Library open
--> Leak

Note: was not able to leak more nsGlobalWindows during the tests and also it does not leak when you close the Places Libary Window before you exist. So this bug might only wanting and not blocking.

Also might another testcase of the leak from Bug 423185

 0 TOTAL                                          43  1661443  1829534    34186 ( 3715.56 +/-  3343.62)  3469822    27372 ( 2823.63 +/-  4267.95)
Flags: blocking1.9?
Flags: wanted-next+
Flags: blocking1.9?
Flags: blocking1.9-
(Reporter)

Updated

10 years ago
Attachment #309695 - Attachment mime type: text/x-log → text/plain

Comment 1

10 years ago
Don't see this on windows: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051011 Minefield/3.0pre

Is this still a problem? Could be related to bug 433231, too.
Component: General → Places
Flags: wanted-next+
Flags: blocking1.9-
Product: Core → Firefox
QA Contact: general → places

Comment 2

10 years ago
Re-asking for the wanted flag that was set before I moved the bug to Firefox:places.
Flags: wanted1.9.0.x?

Comment 3

10 years ago
er, it was wanted-next+.
Wanted, but only barely since it only happens when closing Firefox. We should get this on trunk first.
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x+
Flags: wanted-firefox3.1?
(Reporter)

Comment 5

9 years ago
fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090114 Shiretoko/3.1b3pre by bug 433231  - not leaking anymore with the steps to reproduce
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified per the Leakcat comment #5
Status: RESOLVED → VERIFIED
Flags: wanted-firefox3.5?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.