Empty horizontal scrollbar appears on Google Reader

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: HenkPoley, Assigned: stanshebs)

Tracking

Trunk
mozilla1.9
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

An odd horizontal scrollbar appears on Google Reader posts when you use a menu.

Reproducible: Always

Steps to Reproduce:
1. Open a feed in Google Reader
2. Make sure a bottom of a post is visible (with: add a star, share, e-mail, etc.)
3. Open a menu from the OS X menubar, click an item
Actual Results:  
An empty horizontal scrollbar appears in the bottom of the post.

Expected Results:  
Nothing should change in the rendering.

Comment 1

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031804 Minefield/3.0b5pre

I can confirm this bug on OS X Tiger. Marking NEW, and moving to Layout as a best-guess, since I can't find a dupe. For what it's worth, this has been happening on Mac trunk for a month or two for me. I cannot reproduce this on Windows XP (FFx3 beta 4).

Steps to reproduce:

1. Open any feed in Google Reader
2. Hit space bar to scroll to the next item in the feed
3. Repeat step 2 3-4 times

Expected result: Smooth scrolling, no unnecessary scroll bars

Actual result: Jerky scrolling, horizontal scroll bars appear unexpectedly
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk

Comment 2

11 years ago
Can confirm this on today's nighty 
Assignee: nobody → joshmoz
Flags: blocking1.9+
Priority: -- → P1
help me Martijn you're my only hope
Assignee: joshmoz → nobody
Can I see a screencap of the issue?

I've asked a bunch of people, and nobody can reproduce it on a latest nightly, so it might have been fixed, or a transient Google Reader issue, maybe?

Moving to P2 for tracking, but at this point I can't see us blocking the beta on this issue. If we get stable STR, please reset to P1.
Priority: P1 → P2
Target Milestone: --- → mozilla1.9beta5
Target Milestone: mozilla1.9beta5 → mozilla1.9

Comment 5

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008032104 Minefield/3.0b5pre

Can't reproduce per comment 0 or comment 1, tried both extensively and repeatedly
I can't seem to reproduce this either.
Henk, Jon, are you still seeing this issue in the latest trunk build?

Comment 7

11 years ago
Created attachment 311160 [details]
Screenshot from today's nightly

I am able to reproduce in today's nightly. Just log into Google Reader, read a feed with items bigger than the vertical window size.  Start pressing space bar.  Doesn't happen every time - and sometime is shows up and disappears.  Other times it stays visible.

Comment 8

11 years ago
Created attachment 311161 [details]
Same shot in png format.
Attachment #311160 - Attachment is obsolete: true
Mac only, I guess, I can't reproduce this.
(Reporter)

Comment 10

11 years ago
Created attachment 311165 [details]
Can reproduce spacebar started empty scrollbar

Please note that this the bug is slightly different. The bug report started with empty scrollbar caused by a menu. This image caused by pressing spacebar to scroll down (probably javascript mediated).
(Reporter)

Comment 11

11 years ago
The above screenshot is with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre

Comment 12

11 years ago
(In reply to comment #6)
> I can't seem to reproduce this either.
> Henk, Jon, are you still seeing this issue in the latest trunk build?
> 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008032304 Minefield/3.0b5pre

Yes, I can confirm that this is still 100% reproducible using the steps Schrep listed.
I still cannot reproduce this after quite a lot of playing around in Google Reader.

I do see a weird thing where if an item is wider than the window (e.g. because it contains a wide image or <pre> text), Reader gives it a horizontal scrollbar when the item first comes into view and then takes the scrollbar away before the item scrolls out of view. This scrollbar is in the same position as the scrollbar in Schrep's screenshot, however in my case the scrollbar works and does what you'd expect. I'm pretty sure this is just a Reader feature.
In my case, scrolling back above the item and then hitting space to page down to bring it into view again always makes the scrollbar reappear. For those who are seeing the bug, does that work to show the bug again? Do the items where you see the bug contain content that looks like it is overflowing horizontally?
(Assignee)

Comment 15

11 years ago
I had to dink around with the Planet Mozilla feed for a while in b4 before this one appeared - seemed like I had to shrink the window to get the briefly-appearing-but-valid-looking scrollbar to show with some items that had big images, then after making the window bigger again, I would see the useless scrollbar while paging with the spacebar, at the bottom of every item.

Comment 16

11 years ago
I can confirm this bug. In my case it only happens if I use the spacebar or the "j" and "k" shortcuts to advance or go back in the feed. But if I use the buttons at the bottom of the page ("Previous Item" and "Next Item") to move across the news, the empty scrollbars never appear.
I feel like a klutz, but Stan's approach still doesn't work for me.
(Assignee)

Comment 18

11 years ago
Continuing to experiment with both last night's nightly, and my own debug build, I can't seem to get empty scrollbars at all, *but* the "Alex Polvi: Firefox Sculpture" item has some interesting behavior when you make the window narrower than the images. There seem to be two modes: 1) the images extend to the edge of the window, and are partly clipped by it, or 2) somebody is clipping the images to fit inside the rounded frame enclosing the entire news statement. When it's doing 2), then there will be a scrollbar at the bottom of the item, and it will work properly to scroll the images side to side. When it's doing 1), there is no scrollbar. When I scroll down using the arrow keys when it's in mode 2, the scrollbar poof vanishes when it reaches about the middle of the window, and won't reappear until I scroll down far enough that it's near the bottom of the window.

Although this behavior is rather squirrelly, I see the exact same thing happen viewing the feed with Safari 3.1, so I'm inclined to say that the original bug is gone and what we're now seeing is Google's fault.

(Assignee)

Updated

11 years ago
Assignee: nobody → stanshebs

Comment 19

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre

As of the last couple days, I can no longer reproduce this. Unclear if a change in Gecko or Google Reader resolved the issue, but I've spent a good while scrolling through large feeds and it's not happening anymore. Previously it was easily seen within 5 seconds of playing in Reader.

Comment 20

11 years ago
I believe it is a change in Gecko, using beta4 and beta5 still gives me empty scroll bars, but the latest nightly (Gecko/2008040204 Minefield/3.0pre) it behaves ok.
It would be interesting if someone trawled through the builds to get a precise fix range, but that's not so necessary I guess.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.