Closed Bug 423367 Opened 14 years ago Closed 14 years ago

No scrollbars in third-party themes after bug 395454 landed

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: nickcatal, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031504 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031504 Minefield/3.0b5pre

I am experiences a loss of my vertical and horizontal scrollbar on all pages in all of the tabs on the latest nightly (2008031504)

The only plugin I am using is the "Nightly Tester Tools" plugin and I am using the latest Proto theme.

Reproducible: Always




Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031504 Minefield/3.0b5pre ID:2008031504

Current Plugins:
Adblock Plus 0.7.5.3 [DISABLED]
BugMeNot 1.5 [DISABLED]
ColorfulTabs 2.0.8 [DISABLED]
Coralize 0.9 [DISABLED]
Farkit 2.4f [DISABLED]
FEBE 5.3.1 [DISABLED]
Google Browser Sync 1.3.20070523.0 [DISABLED]
Google Notebook 1.0.0.19 [DISABLED]
Google Toolbar for Firefox 3.0.20070525M [DISABLED]
Greasemonkey 0.7.20080121.0
I ♥ Miro 1.2 [DISABLED]
Image Zoom 0.3 [DISABLED]
Nightly Tester Tools 1.3
NoScript 1.5 [DISABLED]
Slashdotter 1.8.9 [DISABLED]
All third-party themes will need to update what they package for scrollbar CSS, after bug 395454 switched from one chrome URI for Mac and one for everything else to a single URI.
Blocks: 395454
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Summary: Missing scrollbar on all pages/tabs - OS X Proto 2008031504 → No scrollbars in third-party themes after bug 395454 landed
Duplicate of this bug: 423553
Repackaging alone is not enough.  Windows derived themes that repackage as described above still have no scroll bars in Mac OS.
After a thorough review of the Mac and Windows version of scrollbars.css I figured out that the default Windows theme changed the old xulscrollbars.css to scrollbars.css where as Mac's default theme changed the old nativescrollbars.css to scrollbars.css. 

Using the old nativescrollbars.css as scrollbars.css does not work Mac OS. However, using the old nativescrollbars.css as scrollbar.css on Windows would work just fine if bug 423780 were fixed. Using Fixing bug 423780 would make it possible to have one version of scrollbars.css to support all OSes.

Also the default themes for Mac and Windows should use similar scrollbar.css files based on the old nativescrollbars.css file to facilitate custom theme development. Doin this would only require a could of very minor changes to the old nativescrollbars.css for Windows related to background colors (assuming bug 423780 was fixed).
You need to log in before you can comment on or make changes to this bug.