Closed Bug 423495 Opened 12 years ago Closed 12 years ago

Web pages no longer rendered in JAWS virtual buffer, effective March 16, 2008.

Categories

(Core :: Disability Access APIs, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla1.9beta5

People

(Reporter: MarcoZ, Assigned: aaronlev)

References

Details

(Keywords: access)

Attachments

(1 file)

The last build that was fine was Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre.
The checkins of that period were: http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-03-15+00:00&maxdate=2008-03-16+05:00&cvsroot=/cvsroot

STR:
1. Run late3st nightly with JAWS.
2. Go to any web page.

Result:
Marco: Any page comes up blank.
Rob Gallo: First page comes up OK, subsequent come up blank.
Aaron: Trouble reproducing.
Flags: blocking1.9?
More info: It only reproduces for me if my default page is about:blank. If I set a different homepage, everything is fine until I open a new tab and try to go to a page there. Then, not only do pages in the newly opened tab go blank, but also the initially working tab stops working.
The problem is that we return NULL for get_Title() when it's empty, instead of an empty string. We can still return S_FALSE but we need to return a string.
Regression caused by bug 421650.
Attachment #310090 - Flags: review?(surkov.alexander)
Attachment #310090 - Flags: review?(surkov.alexander)
Since it's just a partial backout of 2 lines from bug 421650 I just went ahead and did it. However I want us to look at where else returning NULL with S_FALSE could cause any issues with earlier versions of JAWS.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
It's the rule for MSAA/IA2 but possible it should be an exception for our MSAA extension interfaces. It would be nice if we'll document it.
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031806 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.