Closed Bug 423564 Opened 14 years ago Closed 14 years ago

Bugzilla throwing css errors on console in Firefox because of Opera-specific css

Categories

(Bugzilla :: User Interface, defect)

3.0.3
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: justdave, Unassigned)

References

Details

(Keywords: regression)

From bug 388723 comment 36:

>Note that Firefox now throws tons of warnings in the Error console about these
>two lines:
>
> white-space: -pre-wrap;     /* Opera 4-6 */
> white-space: -o-pre-wrap;   /* Opera 7 */
>
>It seems it doesn't know what to do with them.

Any way to only send that to Opera browsers and get Firefox to ignore it?
I know Internet Explorer has some sort of <!--#if construct or similar that you can mask such things with for IE...
(In reply to comment #1)
> I know Internet Explorer has some sort of <!--#if construct or similar that you
> can mask such things with for IE...
> 

Yes, for instance: http://www.quirksmode.org/css/condcom.html
On the other hand, the Error console in Opera 9.50b shows tons of Firefox-specific css, such as -moz-foo. There is no reason for Bugzilla to be Firefox centric. We should be fair and also find a way to use -moz-foo with Gecko-based browsers only.
I don't want to start doing browser-sniffing, though. That can be a maintenance nightmare. We should see if there is some way for the browsers themselves to ignore certain CSS.
Severity: normal → minor
(In reply to comment #4)
> I don't want to start doing browser-sniffing, though.

We are not suggesting browser-sniffing, at least using JS. <!--[ifIE]> is a HTML tag seen as a comment by other browsers so that we can pass stuff to IE only. I asked mconnor on IRC, and Fx doesn't have such a feature, unfortunately.
(In reply to comment #4)
> We should see if there is some way for the browsers themselves to
> ignore certain CSS.

See bug 393757.
Just filed bug 433172.
It sounds like this is a WONTFIX (or maybe INVALID, since it's not a bug in Bugzilla), then, since Bugzilla will rely on browsers to do the Right Thing™ when confronted with vendor-specific CSS tags. Bug 433074 covers the current work for Gecko.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
For now, this is neither WONTFIX nor INVALID. The CSS code in question is in our CSS files. Unless we can prove there is no better solution than what we have now, this bug remains open.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Status: REOPENED → NEW
Comment 3 and comment 4 indicate that fixing this within the parameters of a current Firefox build is impossible, and that the "problem" lies elsewhere. I dunno how that's not INVALID or WONTFIX, but sure, doesn't matter to me.
Actually, I'd say this is INVALID. That is, it essentially represents a bug in the browser, that it throws warnings about tags that it should just be ignoring. It's true that it still *happens*, but it's not something that we can really do something about, so it's INVALID in the sense that it's "not our bug."
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → INVALID
Target Milestone: Bugzilla 3.0 → ---
You need to log in before you can comment on or make changes to this bug.