Autocomplete should prefer URL matches over title matches

VERIFIED DUPLICATE of bug 409895

Status

()

Firefox
Address Bar
--
enhancement
VERIFIED DUPLICATE of bug 409895
10 years ago
10 years ago

People

(Reporter: Matt Hardy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

When typing a URI into the address bar (e.g. the URL news.bbc.co.uk), the sort on the results returns them sorted by most visited (or at least appears to), which means that I have to scroll through many results to get to the URL which closest matches my address...  The new advanced site selection mechanism is very nice, but it should sort by the domain component of the URL before the title!

Reproducible: Always

Steps to Reproduce:
1. Visit http://news.bbc.co.uk/
2. Visit http://www.anandtech.com/
3. Begin typing into the address bar "news" and you will see that http://www.anandtech.com matches before http://news.bbc.co.uk/.
Actual Results:  
The URL that is first in the search list is "Anandtech: your source for hardware analysis and news".

Expected Results:  
The first match should be BBC News, because I am more likely to be typing in a URL than a site name.

I am not suggesting that sorting on URL should be the only way to do this.  If people want to only type in site names, then this is an amazingly useful feature.  However, there needs to be an option to choose to sort on URL before title (but still search on title after URL).  What would be a more useful feature for advanced users is to always present the base domain URL before the URL with the path.  e.g. if I visit "http://foo.bar/a/path", then next time I type foo, I would want the first match to be "http://foo.bar/" and the second to be "http://foo.bar/a/path".

Updated

10 years ago
Component: General → Location Bar and Autocomplete
QA Contact: general → location.bar
Summary: Sort order based primarily on title, rather than URL → Autocomplete should prefer URL matches over title matches

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409895

Comment 2

10 years ago
Please try beta 4 which has adaptive learning, so after the first time you type news and select news.bbc.co.uk, the second time will have news.bbc.co.uk show up when you type "n".
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.