Not Loading SWF Object Imported from XHTML Document

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Weston Ruter, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-07-30], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

If an XMLHttpRequest is made for an XHTML document (with MIME type application/xml+xhtml) and a SWF object in the responseXML document is inserted into the requesting page, the object fails to load. If, however, the same page is loaded in the browser (without the XHR request) then the object is loaded successfully. The correct behavior happens in Opera 9 and Safari 3, and this bug is a regression from Firefox 2.

Reproducible: Always

Steps to Reproduce:
Load via XHR an XHTML document with SWF object element
Actual Results:  
SWF object fails to load

Expected Results:  
SWF object would load, as it does in FF2, Opera 9, and Safari 3.

See URL for demonstration of issue.
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 3.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.