Closed Bug 4237 Opened 21 years ago Closed 19 years ago

Line breaking-line which contains "\" and "??" does not break.

Categories

(Core :: Internationalization, defect, P3, major)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED
mozilla0.8

People

(Reporter: teruko, Assigned: shanjian)

References

()

Details

(Keywords: intl)

Attachments

(2 files)

Tested 3-23-99 Win32 build.

In the above URL page, the test case #3 has Hankaku "\" and the test case #16 has Zenkaku "��".
After both "\" and "��" are Zenkaku numbers.  They do not break lines even though you move mouse
to change the window size. They should break lines.
Target Milestone: M4
Status: NEW → ASSIGNED
We should break between number followed by a "\", but not "\" followed by
number. Currently, it does not break in neither places.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fix it and check in today. The case #16 should be fine now. The #3 should be
correct if we really convert the Shift JIS into Yen sign. It currently does not
break because it is converted into U+005C. (It work if we use ¥). The #3
problem now is only the conversion issue reported as 4238
Depends on: 4238
I tested this in 2000-09-21-08 Win32, 2000-09-21-04 Mac, and 2000-09-21-10 Linux 
build.  This does not work.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
unsetting target milestone, M4 has been out for a long time.
Summary: Line breaking-line which contains "\" and "��" does not break. → Line breaking-line which contains "\" and "??" does not break.
Target Milestone: M4 → ---
Keywords: intl
I think this is regression. Reassign to shanjian
Assignee: ftang → shanjian
Status: REOPENED → NEW
Keywords: nsbeta1
Target Milestone: --- → mozilla0.8
This might be related with a change I made in line breaking. We are using 
dominating space if there is no CJK character involved. And because unicode 
is used for internal processing, zenkaku character might not be necessarily 
considered as CJK character. It is well understood that no Word/Line break 
algorithm is perfect, and I believe the above behavior is compromisable.
Status: NEW → RESOLVED
Closed: 21 years ago19 years ago
Resolution: --- → WONTFIX
This works fine in 4.x.  This follows the Japanese kinsoku rule.  I reopen this.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Attached patch patch part 1Splinter Review
Attached patch patch part 2Splinter Review
Status: REOPENED → ASSIGNED
explaination about the 2 changes:
1, if a ZenKaku character is met, we go to CJK route. Unicode 
   code point in range of ff00 to ffff is added. (Yes, I know 
   some code points in this range is not yet or will never be 
   allocated.)
2, In CJK route, 0x5c restore back to its category according to 
   4501. 
sr=ftang
sr=erik
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
Verified in 2001021204 Mtrunk build.
Status: RESOLVED → VERIFIED
Blocks: 223707
You need to log in before you can comment on or make changes to this bug.