Closed Bug 423703 Opened 14 years ago Closed 14 years ago

Use jemalloc on Windows SeaMonkey

Categories

(SeaMonkey :: General, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.0a1

People

(Reporter: sgautherie, Assigned: kairo)

References

Details

(Keywords: memory-footprint)

Per "Newsgroups: mozilla.dev.apps.seamonkey":
{{
Philip Chee wrote:
> Are we actually using jemalloc on Windows trunk builds yet?

Not yet, but we now have a tinderbox that can build with it, we should file a bug on it.

Robert Kaiser
}}
Ted, what else except setting --enable-jemalloc in the mozconfig do we need to do for this? Anything regarding CRTs?
Assignee: general → kairo
Nope, that's it.
Checked in, this should be fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
On Windows, mozcrt19.dll is missing from the installer, maybe it's not in the .zip package as well.
checked in the change to have the same #ifdef as FF in packaging with r=ted via IRC.
["Mid-air collision", but I'm posting the comment yet.]

(In reply to comment #4)
> On Windows, mozcrt19.dll is missing from the installer, maybe it's not in the
> .zip package as well.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032801 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Still works fine.

But "2008-03-28-04-trunk" <seamonkey-2.0a1pre.en-US.win32.zip> is broken.
(Now, that bug is a blocker...)
This appears to have generated bug 425771.
Duplicate of this bug: 425771
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032816 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

V.Fixed, confirming bug 425771 comment 4.
Status: RESOLVED → VERIFIED
Keywords: footprint
Target Milestone: --- → seamonkey2.0alpha
You need to log in before you can comment on or make changes to this bug.