Use online help at support.mozilla.com (SUMO) instead of in-product help

RESOLVED DUPLICATE of bug 423486

Status

()

RESOLVED DUPLICATE of bug 423486
11 years ago
11 years ago

People

(Reporter: steffen.wilberg, Assigned: steffen.wilberg)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

11 years ago
Before the help viewer can be removed (bug 423486), we need to point the help links to SUMO.

Entry points are:
1. Menu Help -> Help Contents and For Internet Explorer Users,
2. the Help buttons in the options window.

I've got a wip patch for 1.
Flags: blocking-firefox3?
(Assignee)

Comment 1

11 years ago
Created attachment 310370 [details] [diff] [review]
wip for the help menu

This works fine for the Help menu. The menu items and the F1/Cmd+? keys open the respective SUMO page in a new tab.

The ifdefs in firefox.js won't be necessary once bug 414353 comment 23 is addressed.
Assignee: nobody → steffen.wilberg
Status: NEW → ASSIGNED
(Assignee)

Comment 2

11 years ago
The options window is a bit trickier. The code for that lives in toolkit/content/widgets/preferences.xml. I need to find out how to open a new browser tab from there. But maybe we want a new window instead, since the options window is modal...

Comment 3

11 years ago
What about help with connecting to the web, setting up proxies, and such?
Going to do it all in bug 423486, the summary there is misleading, really.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 423486
Attachment #310370 - Attachment is obsolete: true
No longer blocks: 423486
No longer depends on: 414353
You need to log in before you can comment on or make changes to this bug.