"Click here to add a new task" does not select task-enable calendar

VERIFIED DUPLICATE of bug 412803

Status

Calendar
Tasks
VERIFIED DUPLICATE of bug 412803
10 years ago
10 years ago

People

(Reporter: klint, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b5pre) Gecko/2008031806 Minefield/3.0b5pre
Build Identifier: Lightning 20080319

In the today pane, adding a new task trough the "click here to add a new task" field does not select task-enabled calendars only (as a right-click "New task" popup would do)  but the current calendar.

Reproducible: Always

Steps to Reproduce:
1. Select a calendar which is not task-enabled (Google calendar for instance)
2.Go to Today pane, and enter a new task in the "Click here" field

Actual Results:  
An error pops up and the task cannot be created, because the selected calendar is used to store the task (and it does not support tasks)

Expected Results:  
The same calendar should be calculated as in the pop-up that allows to create a new task when using the "Add task" from contextal menu (ie a calendar that is task enabled, so, not a Google one).

Comment 1

10 years ago
In my opinion related to or even similar to Bug 413326:
  Bug 413326 - adding to read-only calendar
  Bug 423871 - adding to non-read-only calendar that doesn't support tasks
Both need the same solution.
We now have a gray text that tells the user to select a writable calendar and a calendar that supports tasks, which keeps the user from creating tasks on such calendars.

I think the rest of this can be marked duplicate of bug 412803. Do you guys agree?
(In reply to comment #2)
> I think the rest of this can be marked duplicate of bug 412803. Do you guys
> agree?

+1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412803

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.