sessionstore.js not cleared/removed after setting browser.sessionstore.enabled to false

RESOLVED INVALID

Status

()

Firefox
Session Restore
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Michael Ryan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

When browser.sessionstore.enabled is set to false, the sessionstore.js file in the profile folder should be removed whenever Firefox exits. Instead, it just stays there forever (with whatever data was in there last).

Reproducible: Always

Steps to Reproduce:
1. Set browser.sessionstore.enabled to true (default value).
2. Close and reopen Firefox.
3. Go to google.com.
4. Set browser.sessionstore.enabled to false.
5. Close Firefox.
6. Open Firefox.
7. Close Firefox.
Actual Results:  
sessionstore.js contains session data ("google.com", etc) after closing Firefox for the last time.

Expected Results:  
sessionstore.js should be cleared of private data or removed entirely.

Workaround: Manually delete sessionstore.js.

Comment 1

10 years ago
browser.sessionstore.enabled is supposed to be used by extensions only - and those can take care of sessionstore.js themselves (as they might still have use for it).

As a privacy concerned user, the pref to toggle is browser.sessionstore.resume_from_crash which deletes sessionstore.js as expected.

So unless I've overread a specific use case in your bug description, this bug as filed is INVALID.
Whiteboard: [invalid?]
(Reporter)

Comment 2

10 years ago
browser.sessionstore.resume_from_crash does remove the file, but only at startup and only if browser.sessionstore.enabled is true. There does not appear to be a combination of prefs that removes the file at exit if the file exists. browser.sessionstore.enabled is the intuitive choice for this behavior.

Why would browser.sessionstore.enabled only be used by extensions?

Comment 3

10 years ago
(In reply to comment #2)
> browser.sessionstore.resume_from_crash does remove the file, but only at
> startup and only if browser.sessionstore.enabled is true.

The file should be removed whenever you set resume_from_crash to false. A requirement for this to work is however that the SessionStore component is activated (i.e. that browser.sessionstore.enabled is true when Firefox starts). 

> Why would browser.sessionstore.enabled only be used by extensions?

Because it completely disabled the SessionStore component, having several unintuitive consequences (such as Recently Closed Tabs not working or the ones you're reporting in this bug).

Now, does resume_from_crash do what you want or do you have different requirements?

Comment 4

10 years ago
Closing as INVALID. If you do in fact have different requirements, please file a new bug of severity "enhancement".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Whiteboard: [invalid?]
You need to log in before you can comment on or make changes to this bug.