Accessibility: Input elements cannot be read when using white text over black background

RESOLVED DUPLICATE of bug 437366

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 437366
11 years ago
11 years ago

People

(Reporter: yehudab, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
blocking1.9.0.1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031804 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031804 Minefield/3.0b5pre

When reverse high contrast mode is selected using Firefox preferences on Mac OS X (white text over black background and "allow pages to choose their own colors" is unchecked), some pages which contain text boxes and buttons cannot be used, since the text color and background color are both black.
This can be seen on Minefield's start page (search field and "go" button).

Reproducible: Always

Steps to Reproduce:
1. Open Minefield/3.0b5pre on Mac OS X 10.4
2. Open preferences and select "Content" tab
3. Under "Fonts & Colors" click on the "colors" button
4. Select black for text, and white for background
5. Uncheck "Allow pages to choose their own colors"
6. Open http://www.mozilla.org/projects/minefield/
7. Type some text in the search field
Actual Results:  
The text in the search field and the text on the "go" button cannot be read (black over black).

Expected Results:  
Both texts should be readable with white over black

See attached screenshots
(Reporter)

Comment 1

11 years ago
(Reporter)

Comment 4

11 years ago
Oops, made a mistake in step 4 in the "steps to reproduce" section. It should be:
4. Select WHITE for text, and BLACK for background

Comment 5

11 years ago
on my Mac os X 10.5 is same like on 10.4.
(Reporter)

Comment 6

11 years ago
Posted file simple testcase
Testcase shows "black on white" label and input field. Both are visible in normal mode. Input field "disappears" in white-on-black accessibility mode.
(Reporter)

Comment 7

11 years ago
Bug still exists in RC2: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; he; rv:1.9) Gecko/2008053008 Firefox/3.0

Comment 8

11 years ago
I can confirm that behavior using Firefox3rc2/Linux. 

I added the following rule to the page style and even than it is not reproducible without also changing the preferences. 
<style>* {color: white; background: black}</style>
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → All
Nominating this for blocking since it affects all users who may require the inverse contrast theme on Mac or Linux.
Flags: blocking1.9.0.1?
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> Nominating this for blocking since it affects all users .. on Mac or Linux.
> 

I have just confirmed that this bug also affects Windows users. Checked Firefox 3.0 RC2 on Windows XP.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Summary: Mac Accessibility: Input elements cannot be read when using white text over black background → Accessibility: Input elements cannot be read when using white text over black background
(In reply to comment #9)
> Nominating this for blocking since it affects all users who may require the
> inverse contrast theme on Mac or Linux.

Don't they have to set certain preferences in order for this to happen?
(Reporter)

Comment 12

11 years ago
(In reply to comment #11)
> Don't they have to set certain preferences in order for this to happen?

Yes, the exact preferences needed to reproduce the bug can be seen in the first attachment: https://bugzilla.mozilla.org/attachment.cgi?id=310558

These preferences, however, are quite common for people with sight impairment.


Flags: wanted1.9.0.x?
Flags: blocking1.9.0.1?
Flags: blocking1.9.0.1-

Comment 13

11 years ago
Sorry to be duping this to a newer bug, but the other one has more discussion.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: wanted1.9.0.x?
Resolution: --- → DUPLICATE
Duplicate of bug: 437366
(Reporter)

Comment 14

11 years ago
(In reply to comment #13)
> Sorry to be duping this to a newer bug, but the other one has more discussion.
> 
> *** This bug has been marked as a duplicate of bug 437366 ***
> 

bug 437366 has more discussion, but they cover the technical side of the bug. This bug has more comments (and keywords) about the end-user side. I will add my view their as well.
You need to log in before you can comment on or make changes to this bug.