Closed Bug 424319 Opened 13 years ago Closed 13 years ago

Warning message is not displayed when opening multiple tabs through Library.

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: pavlo.statseiko, Assigned: mconnor)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre
Build Identifier: Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032005 Minefield/3.0b5pre

Preconditions: 1)user profile should have a lot of favorites. 
               2)'Warn me when opening multiple tabs' option should be checked. 




 




Reproducible: Always

Steps to Reproduce:
Steps to reproduce:
1. Start FF.
2. Select "Bookmarks->Organize Bookmarks" option from main menu.
-> 'Library' window is displayed.
3. Highlight 'Bookmarks Menu' in the left section of the window.
4. And select all favorites displayed in right section (by holding Ctrl; or pressing Ctrl+A)
5. Right click on the highlighted favorites and select "Open All in Tabs"
option.
Actual Results:  
All favorites are opened in separated tabs without any warning
message.

Expected Results:  
warning message should be displayed since 'Warn me when
opening multiple tabs' option is checked.
Confirmed with latest trunk on Windows XP.
Regression window is http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1188758760&maxdate=1188760559
= bug 175124 
Blocks: 175124
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Keywords: regression
Version: unspecified → Trunk
Component: Preferences → Places
QA Contact: preferences → places
Assignee: nobody → mconnor
Flags: blocking-firefox3? → blocking-firefox3-
This works for me.  The warning dialog is shown (browser.tabs.warnOnOpen;true) if attempting to open tabs beyond browser.tabs.maxOpenBeforeWarn;15 
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.