Bookmarks deleted when restoring Bookmarks by <XXX-XX-XX> menu selection

VERIFIED FIXED in Firefox 3

Status

()

Firefox
Bookmarks & History
P2
critical
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: tracy, Assigned: dietrich)

Tracking

({dataloss})

Trunk
Firefox 3
dataloss
Points:
---
Bug Flags:
blocking-firefox3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Seen with: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre)
Gecko/2008032106 Minefield/3.0b5pre

STR:

1) with a new profile, create a few bookmarks.  put some in each; Bookmarks Menu, Bookmarks Toolbar and unsorted bookmarks.
2) create a Bookmarks backup by: 
    A) Opening the Library (Bookmarks > Organize Bookmark
    B) Select Import and Backup > Backup
    C) save it as what is default (in this case: Bookmarks 2008-03-21)
3) attempt Restore from that date by Import and Backup > 2008-03-21

tested results:  The bookmarks created in step 1 are gone from the Bookmarks menu and Bookmarks toolbar. Those in unsorted are still there.

Expected results:  The bookmarks set is restored to the state as it was save to.

I know this is happening on restore and not at backup because if you choose to Restore > Choose File... it works as expected.  

This bug can't be reproduced on Mac because the Date selection doesn't exist there,  only the Choose file...
Flags: blocking-firefox3?
(Reporter)

Updated

10 years ago
Flags: in-litmus?
Easy solution seems to be whenever the user does a Backup, also do/refresh the automatic daily backup. That way this case is covered. It'll break if they name their backup with yesterday's date, but I care less about that case. :)
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
(Assignee)

Comment 2

10 years ago
The patch in bug 422919 restricts the contents of the Restore menu to *.json files.
Depends on: 422919
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [patch in bug 422919]
(Assignee)

Updated

10 years ago
Target Milestone: --- → Firefox 3
(Assignee)

Comment 3

10 years ago
ugh, never mind. /me needs to *read* the STR first...
No longer depends on: 422919
Whiteboard: [patch in bug 422919]
(Assignee)

Updated

10 years ago
Assignee: nobody → dietrich
(Assignee)

Comment 4

10 years ago
Created attachment 311459 [details] [diff] [review]
fix v1
Attachment #311459 - Flags: review?(mano)
(Assignee)

Updated

10 years ago
Whiteboard: [has patch][needs review mano]
Comment on attachment 311459 [details] [diff] [review]
fix v1

>Index: browser/components/places/content/places.js
>===================================================================

>+  get bookmarksBackupDir() {
>+    delete this.bookmarksBackupDir;
>+    var backupDir

unused.

r=mano otherwise.
Attachment #311459 - Flags: review?(mano) → review+
(Assignee)

Updated

10 years ago
Whiteboard: [has patch][needs review mano] → [has patch][has review]
(Assignee)

Comment 6

10 years ago
Checking in browser/components/places/content/places.js;
/cvsroot/mozilla/browser/components/places/content/places.js,v  <--  places.js
new revision: 1.150; previous revision: 1.149
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][has review]
(Assignee)

Comment 7

10 years ago
Created attachment 313101 [details] [diff] [review]
as checked in
Attachment #311459 - Attachment is obsolete: true
(Reporter)

Comment 8

10 years ago
Verified with Windows build from 2008042305
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

10 years ago
added to litmus
Flags: in-litmus? → in-litmus+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.