All users were logged out of Bugzilla on October 13th, 2018

crash in HandleDOMEventForAnchors

VERIFIED DUPLICATE of bug 44266

Status

()

P3
normal
VERIFIED DUPLICATE of bug 44266
19 years ago
19 years ago

People

(Reporter: warrensomebody, Assigned: waterson)

Tracking

({crash})

Trunk
PowerPC
Mac System 8.5
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If you go to aol.com and click on the "My Calendar" link you'll crash:

 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  07816C88  
  088378C0    PPC  077FC928  main+001AC
  08837850    PPC  077FA11C  main1(int, char**, nsISupports*)+009C8
  088375D0    PPC  069A4B84  nsAppShellService::Run()+00054
  08837580    PPC  06180404  nsAppShell::Run()+00040
  08837540    PPC  06180CB4  nsMacMessagePump::DoMessagePump()+00044
  088374F0    PPC  061814DC  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
001B0
  088374A0    PPC  061A2300  Repeater::DoRepeaters(const EventRecord&)+0003C
  08837450    PPC  06153920  nsMacNSPREventQueueHandler::RepeatAction(const 
EventRecord&)+000
14
  08837410    PPC  06153BCC  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+
00244
  08837370    PPC  0760F690  nsEventQueueImpl::ProcessPendingEvents()+00068
  08837300    PPC  0768A634  PL_ProcessPendingEvents+00084
  088372B0    PPC  0768A778  PL_HandleEvent+00054
  08837270    PPC  05703584  nsStreamListenerEvent::HandlePLEvent(PLEvent*)+00050
  08837230    PPC  057051C4  nsOnDataAvailableEvent::HandleEvent()+000E8
  088371E0    PPC  057C0FB8  nsHTTPServerListener::OnDataAvailable(nsIChannel*, 
nsISupports*,
 nsIInputStream*, unsigned int, unsigned int)+01404
  08836E70    PPC  057C34F4  nsHTTPFinalListener::OnDataAvailable(nsIChannel*, 
nsISupports*, 
nsIInputStream*, unsigned int, unsigned int)+0010C
  08836E10    PPC  0412E174  nsDocumentOpenInfo::OnDataAvailable(nsIChannel*, 
nsISupports*, n
sIInputStream*, unsigned int, unsigned int)+00090
  08836DC0    PPC  04237870  nsParser::OnDataAvailable(nsIChannel*, nsISupports*, 
nsIInputStr
eam*, unsigned int, unsigned int)+0034C
  08836CB0    PPC  04236A28  nsParser::ResumeParse(int, int)+0016C
  08836C50    PPC  04236CC8  nsParser::BuildModel()+00094
  08836C00    PPC  042108F8  CNavDTD::BuildModel(nsIParser*, nsITokenizer*, 
nsITokenObserver*
, nsIContentSink*)+001C8
  08836B00    PPC  042110BC  CNavDTD::HandleToken(CToken*, nsIParser*)+00368
  088369F0    PPC  04213280  CNavDTD::HandleStartToken(CToken*)+003B4
  08836980    PPC  04211EFC  CNavDTD::HandleDefaultStartToken(CToken*, nsHTMLTag, 
nsIParserNo
de*)+0030C
  08836900    PPC  04216840  CNavDTD::OpenContainer(const nsIParserNode*, 
nsHTMLTag, int, nsE
ntryStack*)+00188
  088368A0    PPC  04216040  CNavDTD::OpenBody(const nsIParserNode*)+000CC
  08836840    PPC  051330C4  HTMLContentSink::OpenBody(const nsIParserNode&)+
000D8
  088367F0    PPC  0513542C  HTMLContentSink::StartLayout()+00470
  08836690    PPC  050F9EC0  PresShell::InitialReflow(int, int)+00390
  088364A0    PPC  050F9120  CheckForFocus(nsIDocument*)+00858
  08836320    PPC  07474A90  GlobalWindowImpl::Focus()+0045C
  08836240    PPC  0614E41C  nsWindow::SetFocus()+00018
  08836200    PPC  061772AC  nsMacEventDispatchHandler::SetFocus(nsWindow*)+0009C
  088361C0    PPC  0617708C  
nsMacEventDispatchHandler::DispatchGuiEvent(nsWindow*, unsigned 
int)+00090
  08836150    PPC  06151198  nsWindow::DispatchWindowEvent(nsGUIEvent&)+00028
  08836110    PPC  061510A0  nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&
)+000B8
  088360C0    PPC  03F85D78  HandleEvent(nsGUIEvent*)+00064
  08836070    PPC  03F92188  nsViewManager2::DispatchEvent(nsGUIEvent*, 
nsEventStatus*)+007DC
  08835E70    PPC  03F885E0  nsView::HandleEvent(nsGUIEvent*, unsigned int, 
nsEventStatus*, i
nt&)+00224
  08835DF0    PPC  05104854  PresShell::HandleEvent(nsIView*, nsGUIEvent*, 
nsEventStatus*, in
t&)+00398
  08835D50    PPC  05104C70  PresShell::HandleEventInternal(nsEvent*, nsIView*, 
nsEventStatus
*)+0009C
  08835CF0    PPC  051F85CC  nsEventStateManager::PreHandleEvent(nsIPresContext*, 
nsEvent*, n
sIFrame*, nsEventStatus*, nsIView*)+00ACC
  08835680    PPC  052318AC  nsHTMLAnchorElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, n
sIDOMEvent**, unsigned int, nsEventStatus*)+00050
  08835640    PPC  052224C8  
nsGenericHTMLElement::HandleDOMEventForAnchors(nsIContent*, nsIP
resContext*, nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus*)+000C8
 Closing log
(Reporter)

Updated

19 years ago
Keywords: crash

Comment 1

19 years ago
updating component and setting default owner
Assignee: asa → clayton
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 2

19 years ago
ChrisW, please triage these from Clayton's list.
Assignee: clayton → waterson
(Assignee)

Comment 3

19 years ago
Heh, I get this: "Error: Unknown hostname: calendar.aol.com:80". (Both on Win32 
and MacOS.) Adding dependency on Netwerk for now.
Status: NEW → ASSIGNED
Depends on: 42784

Comment 4

19 years ago
Johnny - the top of this stack looks similar to the nsbeta2 bug you were working 
on.  Could this be a duplicate?

  08835CF0    PPC  051F85CC  
nsEventStateManager::PreHandleEvent(nsIPresContext*, 
nsEvent*, n
sIFrame*, nsEventStatus*, nsIView*)+00ACC
  08835680    PPC  052318AC  
nsHTMLAnchorElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, n
sIDOMEvent**, unsigned int, nsEventStatus*)+00050
  08835640    PPC  052224C8  
nsGenericHTMLElement::HandleDOMEventForAnchors(nsIContent*, nsIP
resContext*, nsEvent*, nsIDOMEvent**, unsigned int, nsEventStatus*)+000C8
 Closing log
Yup, from looking at the stack trace it looks like this was related to bug 44266
which was fixed a few days ago, I'm unable to reproduce this on Win32. Feel free
to dup or mark fixed...

Comment 6

19 years ago
Marking this a duplicate of 44266 per Johnny's comments above.

*** This bug has been marked as a duplicate of 44266 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 7

19 years ago
Marking verified dup of 44266.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.