Autocomplete algorithm should match first word too

VERIFIED FIXED in mozilla0.8

Status

MailNews Core
Composition
P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Phil Peterson, Assigned: Jean-Francois Ducarroz)

Tracking

({polish})

Trunk
mozilla0.8
x86
Windows NT
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+] Fix in hand)

(Reporter)

Description

18 years ago
Using 2000-06-13-08 on NT

1. Kimberly Bradway is in my Collected Address Book.
2. Open a compose window
3. Type "kim br" in the addressing widget, no match
4. Type "kimberly br" in the addressing widget, now it matches

Seems like we need to do substring matches on the first word, in addition to the
last word. In 4.x, we called this the "Chris Yeh" problem, since he was in LDAP
as "Christopher Yeh"
(Reporter)

Comment 1

18 years ago
Add 4xp and nsbeta3 keywords
Keywords: 4xp, nsbeta3

Updated

18 years ago
QA Contact: lchiang → esther
Target Milestone: --- → M18

Comment 2

18 years ago
Maybe you should list options which match the whole string first, and options 
which match only one of the words (e.g. `Kit Fr' to match `Christopher Francis') 
after that? Or maybe list options which match any of the words only if there are 
no matches which match the whole string.

Updated

18 years ago
Blocks: 42796
(Reporter)

Comment 3

18 years ago
Personally, I wouldn't want either of those options. I want an alphabetical list
of hits matching the pattern (kim* br*).

A segmented list of matches would be confusing to me (non-sorted would look like
a bug) and deciding to show some matches but not others defeats the purpose of
the autocomplete picker (which is to unambiguously choose the right recipient
based on all possible matches)
No longer blocks: 42796
(Reporter)

Updated

18 years ago
Blocks: 42796
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: polish

Comment 4

18 years ago
adding myself to the cc list.

Comment 5

18 years ago
Mail Triage is marking [nsbeta3-]
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 6

18 years ago
Changing qa assign to myself.
QA Contact: esther → pmock

Comment 7

17 years ago
Add mail3 keyword
Keywords: mail3

Comment 8

17 years ago
*** Bug 62225 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
marking nsbeta1+ and moving to mozilla0.8
Keywords: nsbeta3 → nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta3-] → [nsbeta1+]
Target Milestone: Future → mozilla0.8
(Assignee)

Comment 10

17 years ago
In 4.x, if I type "Kim Brad" in the adressing field, I get back
"Kim@netscape.com, Brad@netscape.com <No match found>. This despite the fact I
have an entry for Kimberly Bradway in my address book. However, 4.x is able to
find her if I type "Brad" but not 6.x. However, as 6.x is not able to
autocomplete several email addresses on the same line (input), It should be
possible to try to match any partial words as described by Phil.

We should try to do the following matches for a dual word input: <xxx> <nnn>
1) <xxx> <nnn> against the display name (last name + first name) Already done by 6.0
2) <xxx> <nnn> against the nick name.Already done by 6.0
3) <xxx> <nnn> against the email address. Already done by 6.0
4) <xxx> against last name and <nnn> against first name
5) <xxx> against first name and <nnn> against last name

And for a one word input: <xxx>
1) <xxx> against display name, 6.0 does that
2) <xxx> against nick name, 6.0 does that
3) <xxx> against email address, 6.0 does that
4) <xxx> against fist name
5) <xxx> against last name (just in case it's different than the display name)
(Reporter)

Comment 11

17 years ago
> In 4.x, if I type "Kim Brad" in the adressing field, I get back
> "Kim@netscape.com, Brad@netscape.com <No match found>. This despite the fact I
> have an entry for Kimberly Bradway in my address book.

I guess 4.x uses a different matching pattern for local AB entries, vs. LDAP
entries. I'm pretty sure "Kim Brad" will match for LDAP autocomplete.

> We should try to do the following matches for a dual word input: <xxx> <nnn>

Sounds very complete. One thing perhaps to keep in mind is that an LDAP filter
string which expresses that logic will be pretty complex.
(Assignee)

Comment 12

17 years ago
Ok, I have implemented the whole logic I'have described earlier.

Now I am looking at sorting the result but I don't know on which criteria to do
it? matches are shown as:
 [firstName] [lastName] <[email address]>

any preference for the sort?
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+] Fix in hand

Comment 13

17 years ago
it's hard to tell until I use it, but I think I like the idea of it being sorted
by the first name.  Only because normally when I autocomplete, I start typing
the first name and so that's how I'd be looking for it in the list.

Comment 14

17 years ago
Sorting by last name would only make sense in those cultures where the surname is 
the last name (e.g. the US and most European cultures). Sorting by first name 
would make sense everywhere (because it's obvious alphabetical order, same as for 
the other uses of auto-complete in Mozilla).

No it should not be a pref. (Just in case anyone suggests that.)
(Assignee)

Comment 15

17 years ago
I've just check in the new algo that solve the initial problem reported in this
bug. I'll open a new bug for the sorting issue.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

17 years ago
Bug 64662 has been filed. Please use it for further discussion about sorting the
autocomplete result and add yourself in the cc list if you are interested.
Thanks

Updated

17 years ago
QA Contact: pmock → fenella

Comment 17

17 years ago
Win32 (2001-02-20-09 mtrunk)
This problem is fixed as originally reported.
Status: RESOLVED → VERIFIED
No longer blocks: 78270
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.