Wingdings-font characters display incorrectly; fontEncoding.properties hack is gone

RESOLVED DUPLICATE of bug 90643

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 90643
9 years ago
7 years ago

People

(Reporter: Helge Skjeveland, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032204 Minefield/3.0b5pre

In the above-cited page, the section (table cell) to the right of the cell containing the legend "Chapters:", at the top, has the words One Two Three Four on two lines, the cardinal numbers in each line separated by &eth (ð); or &ograve (ò); entities, respectively.  Since these are enclosed by <span>s having styles specifying to use the Wingdings font, these entities should instead respectively display as Wingdings' hollow right-pointing or hollow down-pointing arrows. ð or ò appear instead, despite style="font-family: Wingdings" imposed on the <span>.

It works properly in FF 2.0 if the res\fonts\fontEncoding.properties file is hacked to turn off Adobe encoding, and manually mapping in Wingdings (see http://bachware.com/books/computer%20utilization/Preface.htm#symbol_error), but I can find no analogous hack for FF 3.0β.

Opera 9.26 also displays the same behavior (and I've reported that to them).

But, MSIE 7 and 8β work correctly, displaying the hollow arrows, and has never needed a hack.

Reproducible: Always

Steps to Reproduce:
1. Load the above URL into FF 3.0β
2. Look at the Chapters: header, and in cell to its right
3. You will see ðs and òs between the cardinal numbers, instead of the desired hollow Wingdings arrows
Actual Results:  
As in #3, above.

Expected Results:  
Should see the hollow Wingdings arrows, as in MSIE 7 or later.
(Reporter)

Updated

9 years ago
Summary: Windgdings-font characters display incorrectly → Wingdings-font characters display incorrectly

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90643

Updated

9 years ago
Duplicate of this bug: 437673

Comment 3

9 years ago
How popular was the fontEncoding.properties hack?

Is fontEncoding.properties support totally gone in Firefox 3, or is the default version of the file just missing?  (See bug 310654.)

Updated

9 years ago
Summary: Wingdings-font characters display incorrectly → Wingdings-font characters display incorrectly; fontEncoding.properties hack is gone
(Reporter)

Comment 4

9 years ago
I was surprised to see any traffic regarding this old-TTF problem.  I re-edited all my code that was affected by this withdrawn non-Unicode .TTF support, so the affected portions of my book could continue to be read under FF3, commenting out the old code that cited the fontEncoding.propertiews #Symbol section hack that I don't know how popular was; but without it, one cannot use the old-style non-Unicode .TTF (e.g., Wingdings and Webdings) glyphs directly, as they could be in FF2 and can be in MSIE using their codes from Character Map, say.  One must use the &# hack to get them out of the custom-glyph area, and this doesn’t work with Opera and MSIE.  I and Stuart Parmenter bandied this issue over & over with developers, but I got tired of wrangling, and gave up.  I'll re-post the old code at http://bachware.com/books/computer%20utilization/Preface_old.htm#symbol_error, where the failure to render should still be visible if the Windows machine on which the browser is displaying the URL has the Wingdings and Webdings fonts installed.  The problem can also be seen in http://bachware.com/books/computer%20utilization/toc_old.htm. Proceeding to NEXT and then going BACK from each page will load the new versions that do not use the old .TTFs, but instead use graphics of the relevant glyphs, or entities that substitute workably.

Comment 5

8 years ago
Well, if you don't intend to fix this - at least have FF open a dialog window telling the user that it is rendering the page incorrectly. Its damn annoying not to know that what you see on the screen is wrong (and no, the web people don't care about a minority browser)

Comment 6

8 years ago
I agree with Pete, this issue is really annoying... Google "what does j mean" for a sense of how many people still get tripped up by this.

I bet the FF devs don't get many emails from MS Outlook users. Outlook autocorrects emoticons into little winging smileys, but those smileys come across as a weird J symbols if you read them in gmail/hotmail/yahoo via Firefox. (FWIW, it's broken in Opera, too... Chrome gets it right, though.)

Comment 7

7 years ago
Well, for about 1 year I've been getting these "J"s in my Thunderbird e-mail, not knowing what the hell they were.  I finally asked someone at work what they were doing and they didn't have any clue!  So I forwarded them the e-mail and they said it was a smiley...go figure.

So then I watched them compose one in Outlook, and it was turning the smiley [ :-) ] into a graphical one.  After looking at the source from the e-mail I realized it was substituting character "J" of wingdings, thus the source of my problem.

As the previous poster notes, you just have to google "Thunderbird smiley J" or "what is J" or "Thunderbird J"...you get the idea.  This is a common issue.

Now, I'm sympathetic to not wanting to support this ugly hack by Microsoft to enable graphical smileys, that are actually letters.  For one thing, if the message is read in Ascii, it will always be a problem.  However, I can't understand why you can't just display the requested font as intended, provided that font is on your system.  What's so hard about that?

If a font replaces all the Qs with 7s, who am I to say anything?  Display the font, end of story.  It shouldn't require any special work to be able to display these glyphs, should it?

Comment 8

7 years ago
The FontEncoding.properties hack appears to be gone completely :( though it probably is only a question of finding the right file to edit (since there are other .properties files on the /res/fonts directory.

I find this very, very disturbing. (by the way, I am mostly bothered by this bug on thunderbird 3)

Comment 9

7 years ago
I think you mean:

"The FontEncoding.properties hack appears to be gone completely L"

Just kidding P
You need to log in before you can comment on or make changes to this bug.