Wrong nsAutoPtr usage break Mingw build

RESOLVED FIXED in mozilla1.9beta5

Status

()

Core
Graphics
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Bo Yang, Assigned: Bo Yang)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9beta5
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

576 bytes, patch
Stuart Parmenter
: review+
beltzner
: approval1.9b5+
beltzner
: approval1.9+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
There is one line of code break Mingw build of Firefox trunk. And it is :

nsAutoPtr<UniscribeItem> item = us.GetItem(i, this);

The mingw gcc complain that it request a conversion between UniscribeItem* to nsAutoPtr<UniscribeItem>. And after I have searh some code of Mozilla, I can't find any similar usage with nsAutoPtr. Maybe this is a Microsoft C compiler only usage? 

Anyway, I decide to report this as a bug and hope I can get more advice!
Thanks!
(Assignee)

Comment 1

10 years ago
Created attachment 311240 [details] [diff] [review]
A potential patch

Change 

nsAutoPtr<UniscribeItem> item = us.GetItem(i, this);

to

nsAutoPtr<UniscribeItem> item(us.GetItem(i, this));

to make the compiler not complain.

Updated

10 years ago
Blocks: 203303

Updated

10 years ago
Duplicate of this bug: 424510
Comment on attachment 311240 [details] [diff] [review]
A potential patch

Thanks for the patch!
You need to ask review, if you want the patch to get checked in, eventually.
Attachment #311240 - Flags: review?(pavlov)

Updated

10 years ago
Attachment #311240 - Flags: review?(pavlov) → review+
Assignee: nobody → Techrazy.Yang
Status: NEW → ASSIGNED
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Comment on attachment 311240 [details] [diff] [review]
A potential patch

One-line build fix for mingw.
Attachment #311240 - Flags: approval1.9b5?
Attachment #311240 - Flags: approval1.9?
Comment on attachment 311240 [details] [diff] [review]
A potential patch

a1.9b5=beltzner
Attachment #311240 - Flags: approval1.9b5?
Attachment #311240 - Flags: approval1.9b5+
Attachment #311240 - Flags: approval1.9?
Attachment #311240 - Flags: approval1.9+

Updated

10 years ago
Keywords: checkin-needed
Checking in gfx/thebes/src/gfxWindowsFonts.cpp;
/cvsroot/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp,v  <--  gfxWindowsFonts.cpp
new revision: 1.183; previous revision: 1.182
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta5
You need to log in before you can comment on or make changes to this bug.