Loading gmail links in same tab fails.

VERIFIED INVALID

Status

Camino Graveyard
General
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Chris Recouvreur, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080211 Camino/1.5.5 (jedik)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080211 Camino/1.5.5 (jedik)

Inside of gmail any links I open with Camino hang and time out when opened in the same tab. I have no problem opening the link in a new tab however. 

Reproducible: Always

Steps to Reproduce:
1. Log on to gmail
2. Open any email with a link
3. Click link
Actual Results:  
Page does not load.

Expected Results:  
A new page should load.

Comment 1

10 years ago
Your UA indicates that you are using a third-party build, which is not supported. Does this happen with an official build?

Links in Gmail messages should automatically open in a new tab/link. Have you set the hidden SWM pref to force all loads to re-use the same tab?

Comment 2

10 years ago
(In reply to comment #1)
> Links in Gmail messages should automatically open in a new tab/link. Have you
> set the hidden SWM pref to force all loads to re-use the same tab?

I can repro the filed behaviour with this pref set in a trunk build, though I haven't tried 1.5.x yet.

Comment 3

10 years ago
AFAIK that's expected with browser.link.open_newwindow=1; that's why it's not a real pref, and our hidden pref docs explicitly call out that it will break sites.

Comment 4

10 years ago
At least on trunk, it 'used to work' with that pref set. By 'used to work' I mean: the page would fully load in the same tab. It is possible that Gmail changed something in the way they handle URI internally, causing the described behaviour.

Comment 5

10 years ago
Trying this in Minefield with Firebug, I see the same issue (of course), and it flags an error:
C is not defined
zba[a]))}else{return this.Ci[Ee]==a}};Qj[_P].stopPropagation=function $Qj$_P$sto...

I didn't get more out of it, unfortunately. (Firebug and Gmail don't get along so well it seems, as far as debugging is concerned.)
(Reporter)

Comment 6

10 years ago
Yeah it was the single window mode option that seems to break their links. That happens with the official build as well. As soon as I removed the option it unbroke. Thanks.

Comment 7

10 years ago
I'm going to close this as INVALID then, since my understanding is that it's expected that sites that attempt to do complex window manipulation may not work with that setting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
It used to work on branch, too, until Google changed something recently, but as Stuart says the "reuse window" setting isn't fully supported by Gecko and may break stuff.
(In reply to comment #8)
> It used to work on branch, too, until Google changed something recently

Which was rolling out the "Newer Version"; it still works fine in the "Older Version".  Last bugspam from me on this, I promise ;)
You need to log in before you can comment on or make changes to this bug.