Closed Bug 424719 Opened 12 years ago Closed 12 years ago

Firefox leaks nsDocument on http://www.freearcade.com/ when playing a game

Categories

(Core :: General, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cbook, Assigned: bent.mozilla)

References

()

Details

(Keywords: memory-leak)

Attachments

(1 file, 1 obsolete file)

Attached file leak log
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008032320 Firefox/3.0b5pre ID:2008032320

Steps to reproduce:
-> Go to http://www.freearcade.com/
-> Play a game, in this case pool or whatever you like
-> Quit Firefox with the Game Window open
--> Leak

   0 TOTAL                                          20   393668  9512758    12985 ( 5533.11 +/-  3831.14) 10392379     9600 ( 4161.95 +/-  6068.57)
Flags: blocking1.9?
Summary: Firefox leaks on the http://www.freearcade.com/ Site when playing a game → Firefox leaks nsDocument on http://www.freearcade.com/ when playing a game
Really bad when webpages can cause whole documents to get leaked.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
-> me
Assignee: nobody → bent.mozilla
Attached patch Ensure plugin destruction, v1 (obsolete) — Splinter Review
So I can't actually reproduce the nsDocument leak, but I can get plugins to stay alive forever just by moving my mouse over them!
Attachment #311913 - Flags: review?(jst)
This is going to be included late for b5.
Priority: P2 → P1
Target Milestone: --- → mozilla1.9beta5
Comment on attachment 311913 [details] [diff] [review]
Ensure plugin destruction, v1

Actually, nevermind all that. We moved that to bug 425289.

Tomcat, can you still leak anything with that fix applied?
Attachment #311913 - Attachment is obsolete: true
Attachment #311913 - Flags: review?(jst)
Priority: P1 → P2
Target Milestone: mozilla1.9beta5 → ---
(In reply to comment #5)
> (From update of attachment 311913 [details] [diff] [review])
> Actually, nevermind all that. We moved that to bug 425289.
> 
> Tomcat, can you still leak anything with that fix applied?
> 

Ben, i will run tests with this fix included and also try to get better steps to reproduce if i get this nsDocument Leak again. Feedback asap
Tomcat, I'm leaning towards WFM here.
(In reply to comment #7)
> Tomcat, I'm leaning towards WFM here.
> 

yep i agree, so far i can not reproduce the nsDocument leak, will reopen when i'm able to reproduce this leak again.

-> works for me
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: blocking1.9+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.