Saving a password to the PM when one already exists crashes JS for that webpage.

RESOLVED DUPLICATE of bug 419081

Status

()

Toolkit
Password Manager
--
major
RESOLVED DUPLICATE of bug 419081
10 years ago
9 years ago

People

(Reporter: Timothy Farrell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.25 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I have multiple login/PWs saved for the same page.  Whenever I load the page afresh, PM prompts to use a UN/PW combination (this is HTTP Basic Auth).  I manually type in a different one and click OK (or press Enter).  Authentication succeeds.  The page loads and I get the message bar up top saying, "Do you want FF to remember this password..."  If I click "Remember", then (with Firebug running) I can see that this causes a JS error (Firebug shows this error).  The error is typed out in additional information.

Reproducible: Always

Steps to Reproduce:
0.5. Install the lastest Firebug (to observe the error), turn on Firebug
1. Load page with basic auth (PM should have multiple UN/PWs for this page)
2. Type in a UN/PW that is in the PM but is not the one prompted for. Press Enter.
3. Click the Remember button...notice the JS error in Firebug.
Actual Results:  
JS fails to run on loaded webpage.

Expected Results:  
JS should run.

The error reported in Firebug is:

[Exception..."'This login already exists.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: " JS frame <PATH TO COMPONENTS FOLDER HERE>/nsLoginManagerPrompter.js :: anonymous :: line 586 data: no

The line in question in nsLoginManagerPrompter.js is simply:

"pwmgr.addLogin(aLogin);

... in the _showSaveLoginNotification function

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419081
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.