firefox does not support multi-screen setups of X

RESOLVED DUPLICATE of bug 319965

Status

()

RESOLVED DUPLICATE of bug 319965
11 years ago
11 years ago

People

(Reporter: calestyo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080129 Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.6) Gecko/20040206 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080129 Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.6) Gecko/20040206 Firefox/1.0.1

Like most other applications, firefox does not correctly
support X setups where the user has multiple X screens (this is not Xinerama,
but real separate X-screens, e.g 0.0, 0.1, etc.)

When opening an application I expect that it's windows are created on the
screen where I run the application (e.g. via a terminal or via the system
menu).
Of course it's the window manager's duty to place the windows but as firefox
doesn't start a new process for each invocation, this cannot work (because
the windows of a process are always created on the same screen).

When I have a running firefox process, whose windows are on screen 0 and I start
one on screen 1 the firefox from screen 1 should be displayed on screen 1 and not screen 0.

I'm not sure if it's generally not possible that an application displays windows on different X screens but if not,... code must be added to run a new process on the 2nd screen instead of just creating a new windows (from the old process).
Of course this is problematic with firefox's profiles,..

Any ideas?

Reproducible: Always
(Reporter)

Comment 1

11 years ago
This is in principle identical to https://bugzilla.mozilla.org/show_bug.cgi?id=425093

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 319965
You need to log in before you can comment on or make changes to this bug.