###!!! ASSERTION: wrong thread: 'NS_IsMainThread()

RESOLVED DUPLICATE of bug 417623

Status

()

RESOLVED DUPLICATE of bug 417623
11 years ago
10 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({assertion})

Trunk
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008032701 Firefox/3.0pre ID:2008032701

Steps to reproduce:
2 Firefox Windows, one with transfm.com and http://www.arcadetown.com/needformadness/game.asp and got the assertion:

###!!! ASSERTION: wrong thread: 'NS_IsMainThread()', file /debug/mozilla/netwerk/base/src/nsIOService.cpp, line 477

Stack:
nsGetServiceByCIDWithError::nsGetServiceByCIDWithError(nsID const&, unsigned int*)+0x00005058 [/debug/mozilla/firefox-10.5-debug/dist/FirefoxDebug.app/Contents/MacOS/components/libnecko.dylib +0x0002316A]
nsCreateInstanceByContractID::nsCreateInstanceByContractID(char const*, nsISupports*, unsigned int*)+0x00007BD8 [/debug/mozilla/firefox-10.5-debug/dist/FirefoxDebug.app/Contents/MacOS/components/libgkplugin.dylib +0x00016C80]
MRJGetCookie+0x00000072 [/debug/mozilla/firefox-10.5-debug/plugin/oji/JEP/MRJPlugin.plugin/Contents/MacOS/MRJPlugin +0x00011E1C]
Java_JEPCookieHandler_getCookie+0x000000BB [/debug/mozilla/firefox-10.5-debug/plugin/oji/JEP/JavaEmbeddingPlugin.bundle/Contents/MacOS/JavaEmbeddingPlugin +0x00001C9B]
UNKNOWN 0x1b3739b1
UNKNOWN 0x1b36daaa
UNKNOWN 0x1b36ddb0
UNKNOWN 0x1b36daaa
UNKNOWN 0x1b36daaa
UNKNOWN 0x1b36d9d3
UNKNOWN 0x1b36d9d3
UNKNOWN 0x1b36daaa
UNKNOWN 0x1b36daaa
UNKNOWN 0x1b36d9d3
UNKNOWN 0x1b36dcd9
UNKNOWN 0x1b36b227
UNKNOWN [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x0011963A]
UNKNOWN [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x0005D763]
UNKNOWN [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x0005D655]
UNKNOWN [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x0005D595]
UNKNOWN [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x0005D4B8]
JVM_RaiseSignal+0x0006BB65 [/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libclient.dylib +0x002C4CC5]
thread_resume+0x00000113 [/usr/lib/libSystem.B.dylib +0x0007D53B]
I hit this assertion at http://ma7room.com/ along with bug 417623 and bug 417624 at the same site.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417623
You need to log in before you can comment on or make changes to this bug.