Replace use of outputfilter.urlt.php with direct outputting of nicely formatted URLs in links

RESOLVED DUPLICATE of bug 522813

Status

support.mozilla.org
Knowledge Base Software
RESOLVED DUPLICATE of bug 522813
10 years ago
8 years ago

People

(Reporter: nkoth, Assigned: paulc)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Smarty outputfilter.urlt.php is very slow. Will output urls from php instead (to merge with latest SEF URL work in Tiki 1.10).
(Reporter)

Updated

10 years ago
Priority: -- → P2
(Reporter)

Updated

10 years ago
Priority: P2 → P3

Updated

10 years ago
Priority: P3 → --
Target Milestone: 0.6 → 0.7
(Reporter)

Updated

9 years ago
Target Milestone: 0.7 → 0.8
(Reporter)

Updated

9 years ago
Depends on: 446545
Target Milestone: 0.8 → 0.9

Updated

9 years ago
Target Milestone: 0.9 → 1.1

Comment 1

9 years ago
Is this performance related?
Target Milestone: 1.1 → ---
(Assignee)

Comment 2

9 years ago
> Is this performance related?
David: Yes, it's the reason tiki-adminusers.php times out on stage, actually.(In reply to comment #1)

Comment 3

9 years ago
Paul: is this something you could fix? If so, please assign to yourself and target to 1.0 or 1.1, depending on when you can have it fixed. Thanks!
(Assignee)

Comment 4

9 years ago
I could just turn off the filtering, that'd solve the problem. Basically this function checks if the HTML is safe, I think. I'll investigate. If we can safely turn it off, this can make it into 1.1. I could just turn it off now and we can test to see if something goes wrong :)

Comment 5

9 years ago
Let's assume that it's there for a reason. Nelson, if you can clarify, that'd be helpful!

Updated

9 years ago
Assignee: nelson → smirkingsisyphus
Target Milestone: --- → 1.3

Comment 6

9 years ago
I think this is the same issue ecooper was talking about the other day - assigning to him.
(Assignee)

Comment 7

8 years ago
Nelson, could you maybe detail how Tiki is currently doing it?

Updated

8 years ago
Target Milestone: 1.3 → 1.5
(Assignee)

Updated

8 years ago
Assignee: smirkingsisyphus → paul.craciunoiu
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522813
You need to log in before you can comment on or make changes to this bug.