Multiple identical links with the same accesskey can't be activated via keyboard

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
--
minor
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Dan Dascalescu, Unassigned)

Tracking

({regression})

1.9.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Consider this piece of HTML:

<a href="http://yahoo.com" accesskey="A">Y_a_hoo!</a>
<a href="http://google.com" accesskey="G">_G_oogle</a>

Shift+Alt+A works as expected.
Let's add an identical link (supposedly at the bottom of the page, for usability) with the same accesskey:


<a href="http://yahoo.com" accesskey="A">Y_a_hoo!</a>
<a href="http://google.com" accesskey="G">_G_oogle</a>
<a href="http://yahoo.com" accesskey="A">Y_a_hoo!</a>

Shift+Alt+A now switches focus between the two "Yahoo" links.

Reproducible: Always

Steps to Reproduce:
1. Go to http://twiki.org/cgi-bin/view/Main/TWikiSuccessStoryOfTakeFive
2. Press the keyboard combination to activate the Edit link (e.g. Shift+Alt+E)
3. Notice that the Edit link received focus, but was not "clicked"
Actual Results:  
Focus jumps between the two "Edit" links in the page when pressing the accesskey E.

Expected Results:  
Firefox should surf to the Edit link.

With elements other than links, not activating them because they have conflicting accesskeys is a good idea. For links with identical HREF's, it is irrelevant which one gets activated.

This bug did not exist in Firefox 2.

Updated

10 years ago
Flags: blocking-firefox3?
this is minor at worst, trivial at best.  Its an extra keypress to activate the link, and the "totally identical" case seems mostly overly-narrow.
Flags: blocking-firefox3? → blocking-firefox3-

Updated

10 years ago
Flags: blocking-firefox3.1?

Comment 2

10 years ago
I can't believe it's still "UNCONFIRMED".. go, try it yourself!

For example:

  http://www.dokuwiki.org/playground:test

Try to press Shift+Alt+E to create or edit the page. This worked just fine in Firefox 2.

Comment 3

10 years ago
Note that the links can still be activated via keyboard, just no longer with a single key combination. Treating multiple links with the same target as one might be a sensible optimization, though.
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → Keyboard: Navigation
Ever confirmed: true
Flags: blocking-firefox3.1?
Flags: blocking-firefox3-
Keywords: regression
Product: Firefox → Core
QA Contact: keyboard.navigation → keyboard.navigation
Whiteboard: [wontfix?]
Version: unspecified → 1.9.0 Branch

Comment 4

9 years ago
In firefox 2.x Accessibility.accesskeycausesactivation is working as expected (activating the link - even though there's two identical accesskeys).

In firefox 3.x this is NOT working! IF Accessibility.accesskeycausesactivation is set to true, it should activate... if not - it should focus! (imo - to preserve the same behavior)

Comment 5

2 years ago
Not reproducible in windows-XP with latest Nightly and release.
Considering this, I will mark this issue as Resolved-WORKSFORME. If anyone can still reproduce it, feel free to reopen the issue and provide more information. Thanks

--
Version 	48.0a1
Build ID 	 20160407030221
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:48.0) Gecko/20100101 Firefox/48.0
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.