Closed Bug 425506 Opened 12 years ago Closed 12 years ago

Crash when a local SWF file tries to communicate with the internet and Javascript is deactivated [@ 0xffff061a][@ ns4xPluginStreamListener::CallURLNotify]

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

All
macOS
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: whimboo, Assigned: msintov)

References

()

Details

(Keywords: crash, Whiteboard: [fixed in flashplayer10 plugin 051508])

Crash Data

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032704 Minefield/3.0pre ID:2008032704

I run into this crash while testing the beta5 rc2. I saved the homepage of nytimes as "Web Page, complete" and opened it again from the local disk. Everything is fine until you deactivate JavaScript. From now on Firefox crashes when you load or even reload the page. The crash only happens under OS X. Repeating the following steps under Windows an error/warning dialog by the Flash player is shown:

(roughly translated)
"Flash player has stopped a possible insecure process.

The following application from your computer or network:

C:\The New York Times - Breaking News, World News & Multimedia_files\shell_data\flvPlayer.swf

tried to communicate with an online data storage"

It looks like that local Flash files which tries to retrieve data from the internet causes Firefox to crash when Javascript is deactivated. This only happens under OS X. I cannot reproduce it under Windows XP.
Flags: blocking1.9?
Running my debug build shows that frame 13 is the latest one in our source:

(gdb) frame 12
#12 0x3fbb0c78 in Flash_EnforceLocalSecurity ()
Xcode could not locate source file: cpu_capabilities.h (line: 226)
(gdb) frame 13
#13 0x2e5153ff in ns4xPluginStreamListener::CallURLNotify (this=0x36ce5e40, reason=1) at /Users/henrik/Projects/mozilla/source/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp:215
Xcode could not locate source file: cpu_capabilities.h (line: 226)
215	in /Users/henrik/Projects/mozilla/source/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp

The appropriate source:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp&rev=1.146&mark=215-219#196

Analyzing mNotifyURL returns following value:

(gdb) p mNotifyURL
$2 = 0x3dcced40 "file:///Users/henrik/Desktop/flvPlayerConfig.xml"
Xcode could not locate source file: cpu_capabilities.h (line: 226)

This file doesn't exist on my desktop. So could this be the cause of the crash?
Even crashes Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14pre) Gecko/20080327 BonEcho/2.0.0.14pre

I don't think that it is our fault. Michelle, could you have a look at it? In my case it happens with Flash 9 r115.
Assignee: nobody → msintov
Here the crash report I forgot in comment 0: bp-004f27f5-fc28-11dc-99db-001a4bd43ef6
We will try to reproduce the crash in-house. Thanks for the bug report.
Unfortunately, we don't crash when we follow the steps described in comment #0 on Mac OS 10.4 with Firefox 2.0.0.13.
You have deactivated JavaScript before loading the locally saved page?
Our response to comment #6 is Yes.
Reproduced in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008033104 Minefield/3.0pre and Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/2008020121 Firefox/2.0.0.12 on OS X 10.5.2.
In Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.13) Gecko/2008031115 Firefox/2.0.0.13 on OS X 10.5.2 as well.
Detailed STR:

1. Create a fresh profile
2. Deactive JavaScript under "Preferences | Content"
3. Open URL and save it to local disk
4. Open page from local disk
=> Crash

This let me crash any Firefox version each time I open the locally saved page. Sounds strange that you cannot reproduce it.
Apologies, and thanks for your persistence. I just reproduced the crash. We will investigate.
-'ing this as it's only a crash w/ JS disabled and loading a local flash file.  Please feel free to argue.  Also, do we know if this is a regression from 2.0?
Flags: blocking1.9? → blocking1.9-
Happens with 2.0 too.
Damon, for the moment we should wait for the results Michelle could give us. They did an internal investigation. No idea if this is our fault or on Adobes site.
Thanks again for the bug report. The Flash Player team has fixed this bug internally and it will be included in a future release.
Michelle, that sounds great. Do you mean with future release the next official release or a later one?
Excellent.  Thanks for the feedback, Michelle.  :)

Marking resolved/invalid.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
verified -> plugin issue :)
Status: RESOLVED → VERIFIED
I will report back to this bug when a Flash Player with this bug fix is released.
This bug should now be fixed in the Flash Player 10 beta: http://labs.adobe.com/downloads/flashplayer10.html
Michelle, I tested the mentioned beta version of the Flash player 10 and everything works fine. Thanks for your efforts to fix this crash.
Whiteboard: [fixed in flashplayer10 plugin 051508]
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Resolution: INVALID → FIXED
Target Milestone: --- → May 2008
Version: Trunk → 9.x
Crash Signature: [@ 0xffff061a] [@ ns4xPluginStreamListener::CallURLNotify]
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: May 2008 → ---
Version: 9.x → unspecified
You need to log in before you can comment on or make changes to this bug.