Undo function does not work for deleted tags in the Library

VERIFIED FIXED in Firefox 3

Status

()

Firefox
Bookmarks & History
P2
major
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: whimboo, Assigned: mano)

Tracking

({dataloss, regression})

Trunk
Firefox 3
dataloss, regression
Points:
---
Bug Flags:
blocking-firefox3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032704 Minefield/3.0pre ID:2008032704

When you delete a tag within the Library it is not possible to undo the step. The deleted tag is definitely gone. Doing the same with a bookmark restores it on the old place.

Steps to reproduce:
1. Open the Library and tag a bookmark
2. Goto "Tags" and click the new tag
3. Select the bookmark under this tag and hit delete
4. Goto "Edit | Undo"

The deleted tag should be restored but it's not done at the moment. There is no chance to get back a deleted tag. Setting keyword dataloss accordingly.
Flags: blocking-firefox3?
I see same in Windows/Vista HP 
Existing tagged bookmarks can be 'undone' 
but a New tag created in the Organizer, once deleted cannot be 'undone' 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008032705 Minefield/3.0pre Firefox/3.0 ID:2008032705
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Existing tagged bookmarks can be 'undone' 
> but a New tag created in the Organizer, once deleted cannot be 'undone' 

What do you mean with existing tagged bookmarks? I did following steps and it also doesn't work:

1. Open a website and hit Cmd+D.
2. Give the bookmark a tag
3. Open Library and delete the entry under this tag
=> Undo doesn't work.
I mean a bookmark that I had tagged some time ago, seems to be able to be 'undone'.  

Appears that the creation of new tags is the problem then. 

(Reporter)

Comment 4

10 years ago
Regression from between 2008-02-01 and 2008-03-01. Will try to get the regression window tomorrow.
Keywords: regression
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Summary: Undo function does not work for deleted tags in the Library → Undo function does not work for deleted tags in the Library (after a certain date?)
(Reporter)

Comment 5

10 years ago
This regressed between 20080206-04 and 20080207-04.

Checkins within this timeframe:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-02-06+03%3A00%3A00&maxdate=2008-02-07+04%3A00%3A00&cvsroot=%2Fcvsroot

Possible related: bug 332047, bug 411088

I think this is caused by the patch on bug 411088. Seems that we fail because we cannot undo the deletion of a formerly empty tag.

I hope it's ok to set Asaf as assignee for this bug because his patch caused this issue.
Assignee: nobody → mano
Depends on: 411088
Summary: Undo function does not work for deleted tags in the Library (after a certain date?) → Undo function does not work for deleted tags in the Library

Updated

10 years ago
Whiteboard: [needs status update]
Status: NEW → ASSIGNED
Whiteboard: [needs status update] → [has patch][needs review dietrich]
Target Milestone: --- → Firefox 3
Comment on attachment 313075 [details] [diff] [review]
patch

r=me. are there other instances of container ids passed to the tagging APIs that might be afflicted this way?
Attachment #313075 - Flags: review?(dietrich) → review+
mozilla/browser/components/places/src/nsPlacesTransactionsService.js 1.35
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified Fixed Windows Vista HP SP1

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040212 Minefield/3.0pre Firefox/3.0 ID:2008040212
(Reporter)

Comment 11

10 years ago
Verified.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040504 Minefield/3.0pre ID:2008040504

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040504 Minefield/3.0pre ID:2008040504
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Whiteboard: [has patch][needs review dietrich]
Test case https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=7469 has been added to litmus for regression testing.
Flags: in-litmus? → in-litmus+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.