Firefox Beta 5 RC 2 Crash on Exit after Printing @_objc_error

VERIFIED DUPLICATE of bug 422827

Status

()

Core
General
--
critical
VERIFIED DUPLICATE of bug 422827
9 years ago
9 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash, regression, relnote})

Trunk
x86
Mac OS X
crash, regression, relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

Steps to reproduce:
-> New Profile
-> Go to http://en-us.www.mozilla.com/en-US/firefox/3.0b5/firstrun/
-> File -> Print -> PDF - Safe as PDF
-> Use the Default Values and safe the Page as PDF
-> Close Firefox
--> Crash !

Crash ID http://crash-stats.mozilla.com/report/index/ad896f11-fc69-11dc-a87e-001a4bd43e5c but don't have a stack right now. Will add this later.
Flags: blocking1.9?
(Reporter)

Updated

9 years ago
Keywords: regression
Happens with "Save to Postscript" as well using the B5 RC2 candidate on Leopard.
(Reporter)

Comment 2

9 years ago
0  	_objc_error  	
1 	__objc_error 	
2 	_freedHandler 	
3 	+[NSMenu(NSKeyEquivalents) _removeItem:fromTable:] 	
4 	+[NSMenu(NSKeyEquivalents) _unregisterMenuItemForKeyEquivalentUniquing:] 	
5 	-[NSMenuItem setMenu:] 	
6 	-[NSMenu removeItemAtIndex:] 	
7 	nsMenuX::RemoveAll() 	mozilla/widget/src/cocoa/nsMenuX.mm:414
8 	nsMenuX::~nsMenuX() 	mozilla/widget/src/cocoa/nsMenuX.mm:111
9 	nsMenuX::Release() 	mozilla/widget/src/cocoa/nsMenuX.mm:87
10 	ReleaseObjects(void*, void*) 	nsCOMArray.cpp:151
11 	nsVoidArray::EnumerateForwards(int (*)(void*, void*), void*) 	nsVoidArray.cpp:678
12 	nsCOMArray_base::Clear() 	nsCOMArray.cpp:158
13 	nsMenuBarX::~nsMenuBarX() 	mozilla/widget/src/cocoa/nsMenuBarX.mm:217
14 	nsMenuBarX::Release() 	mozilla/widget/src/cocoa/nsMenuBarX.mm:67
15 	nsCOMPtr_base::~nsCOMPtr_base() 	nsCOMPtr.cpp:81
16 	nsCocoaWindow::~nsCocoaWindow() 	mozilla/widget/src/cocoa/nsCocoaWindow.mm:542
17 	nsBaseWidget::Release() 	mozilla/widget/src/xpwidgets/nsBaseWidget.cpp:69
18 	nsCOMPtr_base::assign_with_AddRef(nsISupports*) 	nsCOMPtr.cpp:531
19 	nsXULWindow::Destroy() 	mozilla/xpfe/appshell/src/nsXULWindow.cpp:713
20 	nsWebShellWindow::Destroy() 	mozilla/xpfe/appshell/src/nsWebShellWindow.cpp:873
21 	nsAppShellService::DestroyHiddenWindow() 	mozilla/xpfe/appshell/src/nsAppShellService.cpp:209
22 	nsAppStartup::DestroyHiddenWindow() 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:160
23 	ScopedXPCOMStartup::~ScopedXPCOMStartup() 	mozilla/toolkit/xre/nsAppRunner.cpp:903
24 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3195
25 	main 	mozilla/browser/app/nsBrowserApp.cpp:158
26 	start 	crt.c:272
27 	start 	
28 	@0x1
Summary: Firefox Beta 5 RC 2 Crash on Exit after Printing → Firefox Beta 5 RC 2 Crash on Exit after Printing @_objc_error

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422827
(Reporter)

Comment 4

9 years ago
yeah its another Case to reproduce the topcrash from Bug 422827. Thanks Timeless

Also i can confirm this is fixed on trunk with the latest Nightly on Mac 
Status: RESOLVED → VERIFIED
Flags: blocking1.9?
(Reporter)

Comment 5

9 years ago
setting relnote keyword, because of the common steps to reproduce.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.