Closed Bug 425592 Opened 12 years ago Closed 10 years ago

early fx3 beta 5 crash [@UniscribeItem::IsGlyphMissing(SCRIPT_FONTPROPERTIES*, unsigned int)]

Categories

(Core Graveyard :: GFX, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: chofmann, Unassigned)

References

Details

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&range_unit=weeks&version=Firefox%3A3.0b5&signature=UniscribeItem%3A%3AIsGlyphMissing(SCRIPT_FONTPROPERTIES*%2C+unsigned+int)&range_value=1

shows several crashes on the 2008 03 26 builds near code that has recently changed

most of these look like start up crashes or within the first couple of minutes of uptime.   no comments on any of the reports yet.

stack looks like

0  	UniscribeItem::IsGlyphMissing(SCRIPT_FONTPROPERTIES*, unsigned int)  	 mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:990
1 	xul.dll@0x28a63e
This really occurred under Mac OS X?!?
no, as it happens they're all vista, but chofmann tends to forget to fill in the field information based on the crash-report data, so bugzilla uses his browser information. offhand, i'd claim this is all one user as the cpu information is identical.
OS: Mac OS X → Windows Vista
yeah, it does look like it could be one user with multiple consecutive tries at trying to get up and running.
still hanging around at #12 ranked top crash for beta 5 so it turns out this was not one user...
Depends on: 429148
Depends on: 427411
I was seeing this when uninstalling a font as an admin user and then restarting Firefox as another user before that user logged out and logged in again.

(Bug 418382 comment 2)

I suspect that bug 418382 may have morphed into this bug.
Blocks: 418382
Version: unspecified → Trunk
(In reply to comment #5)
> I was seeing this when uninstalling a font as an admin user and then restarting
> Firefox as another user before that user logged out and logged in again.

Oh.  But I can now no longer reproduce with those steps and build id 2008042106.
I now only see the symptoms consistent with bug 427411 comment 24.
Previously I could always reproduce so something has changed, but there are still crash reports with the same stack (or lack of stack) coming in:

http://crash-stats.mozilla.com/report/list?range_unit=weeks&query_search=signature&query_type=contains&product=Firefox&platform=windows&version=Firefox%3A3.0pre&signature=UniscribeItem%3A%3AIsGlyphMissing%28SCRIPT_FONTPROPERTIES%2A%2C+unsigned+int%29&query=UniscribeItem&range_value=3
Product: Core → Core Graveyard
Very few crashes here nowadays.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.