Closed Bug 425760 Opened 12 years ago Closed 12 years ago

https://www.mozilla.com/certs/mozilla-root.crt is not sending the correct content/type

Categories

(www.mozilla.org :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cbook, Assigned: reed)

References

()

Details

Steps to reproduce:
Go to http://wiki.mozilla.org/MozillaRootCertificate#Mozilla_Firefox and click on the Cert Link - you should see the Cert Manager, but instead you see the text output of the Cert.

Its not a Problem of the Cert Manager, other certs from other sites work.
Summary: https://www.mozilla.com/certs/mozilla-root.crt is not sending the correct ot sending the right content/type → https://www.mozilla.com/certs/mozilla-root.crt is not sending the correct content/type
Yeah, I get a content-type of text/plain

On Kai's test-ca link here (which does work): http://kuix.de/mozilla/certwarndiscussion/test-ca.php

I get

Content-Type: application/x-x509-ca-cert
Probably my fault. I'll poke this later.
Assignee: nobody → reed
OS: Mac OS X → All
Hardware: PC → All
Sending        certs/.htaccess
Transmitting file data .
Committed revision 11911.

This should be live within 30 min. or so.
Status: NEW → ASSIGNED
Looks fixed to me.

$ curl -I https://www.mozilla.com/certs/mozilla-root.crt
...
Content-Type: application/x-x509-ca-cert
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
https://www.mozilla.com/certs/mozilla-root.crt.md5sum was sending the wrong content-type due to a bad rewrite rule. I fixed the rewrite rule, but this won't go live until somebody pushes it.

Sending        .htaccess
Transmitting file data .
Committed revision 11912.
verified fixed, thanks reed !
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.