Sessions not restored when clear private data is enabled

RESOLVED DUPLICATE of bug 398817

Status

()

RESOLVED DUPLICATE of bug 398817
11 years ago
10 years ago

People

(Reporter: bmathis-bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Sessions are not restored when "clear private data on exit" is selected, and in the settings "Browsing history" is selected.

Reproducible: Always

Steps to Reproduce:
1. In "Options > Privacy", enable the checkbox "Always clear private data when I close Firefox"
2. Click on the "Settings" button and enable the checkbox next to "Browsing History", then [OK], and [OK] again.
3. Open up a few tabs in the web browser to different sites.
4. Exit the browser, if prompted, select "Yes" to save opened tabs, and Yes to clear private data
5. Start the browser
Actual Results:  
The tabs that were open before closing the browser were not restored.

Expected Results:  
Expected results are that the tabs that were open before exiting the browser should have been restored.  History is cleared as expected, but the open tabs should not be part of the data that was cleared.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
You need to log in before you can comment on or make changes to this bug.