Leak nsDocument with <xul:wizard>, cloneNode

RESOLVED WORKSFORME

Status

()

Core
XBL
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {memory-leak, testcase})

Trunk
x86
Mac OS X
memory-leak, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

449 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

10 years ago
Created attachment 312382 [details]
testcase

Steps to reproduce:
1. Run a debug build of Firefox with XPCOM_MEM_LEAK_LOG=2
2. Load the testcase.
3. Quit.

Result: trace-refcnt reports that an nsDocument has leaked, along with a total of 276895 bytes worth of instrumented objects.

The testcase is related to the testcase for bug 415192, but the testcase in bug 415192 does not trigger this leak.
(Reporter)

Comment 1

10 years ago
It's easiest to reproduce the bug if you quit immediately after loading the testcase (without waiting).
(Reporter)

Updated

10 years ago
Blocks: 429003
Duplicate of this bug: 429003
Works for me on a Linux trunk DEBUG_CC build from yesterday.
(Reporter)

Comment 4

10 years ago
WFM.  Crashtest checked in.  Along with bug 429085, seems to leak when run with -reftest, but so does everything else in content/xul/content/crashtests/ ...
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.