Open Bug 425912 Opened 12 years ago Updated 12 years ago

menulists are too small when no value is set

Categories

(Toolkit :: XUL Widgets, defect)

x86
Linux
defect
Not set

Tracking

()

People

(Reporter: kengggg, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre

BugAThon Bangkok

Reproducible: Always

Steps to Reproduce:
1. Go to Firefox's Preference
2. Under Fonts & Colors Open Advanced... Menu
3. You can see the "Minimum font size:" combo box display value as blank
Actual Results:  
The "Minimum font size:" combox box display value as blank

Expected Results:  
The minimum font size should be "None" if no specific value is set
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414089
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of bug 414089 ***

I think the point of this bug is not preference value but an appearance in the UI (what explicitly visible to user).

See attachment 312450 [details] , you can see that the size of the dropdown list is very thin (it's height is even smaller than the arrows).

Expected result should be, no matter if the preference value has been set or not (null or has some value), the height of the dropdown list should be always the same.


Gavin: Can I reopen this as a Theme/UI bug ?
Component: Preferences → Theme
Sure, we can turn this into a bug for Linux menulists to look better when the value is empty.
Status: RESOLVED → REOPENED
Component: Theme → XUL Widgets
Keywords: uiwanted
Product: Firefox → Toolkit
Resolution: DUPLICATE → ---
Testcase in the URL field works for me on Windows, and based on the screenshot it works on Mac too.
OS: All → Linux
Hardware: All → PC
Summary: Minimum font size preference display blank value if no value has set → menulists are too small when no value is set
Status: REOPENED → NEW
QA Contact: preferences → xul.widgets
You need to log in before you can comment on or make changes to this bug.