IFRAME does NOT respect absolute positioning.

RESOLVED DUPLICATE of bug 410146

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 410146
10 years ago
10 years ago

People

(Reporter: henryfhchan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

IFRAME does NOT respect absolute positioning stated in both external, internal and as an attribute.

Reproducible: Always

Steps to Reproduce:
1. Go to my testcase
2. The iframe should expand.
3.
Actual Results:  
The iframe doesn't expand under firefox 3b4

Expected Results:  
the iframe to expand.
(Reporter)

Comment 1

10 years ago
Created attachment 312491 [details]
testcase

Comment 2

10 years ago
IFRAME is a replaced element and thus 10.3.8 applies:
http://www.w3.org/TR/CSS21/visudet.html#abs-replaced-width

<iframe
...
style="... position:absolute; left:171px; top:0px; right:0px; bottom:0px;"
...

1. the intrinsic width in this case is 300px
2. no, both 'left' and 'right' have values that are not 'auto'
3. no, both 'left' and 'right' have values that are not 'auto'
4. no, margins are not specified and thus have the initial value zero
5. no, 'left' is not 'auto'
6. the styling is over-constrained, since the 'direction' is 'ltr'
   we ignore the specified value for 'right'

The old layout in Firefox 2.x is a bug, per CSS 2.1.
See bug 307102 and bug 412679 for reference.

-> INVALID
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 3

10 years ago
I should say though that it is being discussed on www-style
whether CSS 2.1 makes sense in this case:
http://lists.w3.org/Archives/Public/www-style/2008Feb/0187.html
so I guess we should fix this if the spec is likely to change...

David?

Comment 4

10 years ago
Boris usually marks these issues as a duplicate of bug 410146. That should help to keep track of all these related bugs.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 410146
You need to log in before you can comment on or make changes to this bug.