bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

FF reverts to Google even when other location bar search services are specified

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: andrew.pennebaker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre

I have modified the default keyword.URL search to Yubnub (http://yubnub.org/parser/parse?command=) in about:config. With it I am able to use "g <query>" to redirect to a Google query, "y <query>" for Yahoo, and so on.

Occasionally, FF will not follow the specified search service for searching with the location bar, but instead will display the Google search page results for the Google query "http://www.g <query>".

Upon resubmitting the same query in the location bar, the correct results page is reached. Screenshot for bug: http://i241.photobucket.com/albums/ff300/nilsmilo/keywordurl.png

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
This is what happens if you hold down "Shift" while pressing Enter. Firefox autocompletes "www." and ".net" in that case (it's a variant of Ctrl+Enter, which autocompletes "www." and ".com").

Since it happened with a search that ends in all caps I'm going to assume that that's what happened, and mark this bug INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.