Closed Bug 426011 Opened 14 years ago Closed 14 years ago

Uploading attachments to Bugzilla makes all Camino menus except "Camino" and "Edit" disappear

Categories

(Core :: Widget: Cocoa, defect, P2)

PowerPC
macOS
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla-graveyard, Assigned: jaas)

References

Details

(Keywords: dogfood, regression)

Attachments

(1 file)

2.39 KB, patch
stuart.morgan+bugzilla
: review+
Details | Diff | Splinter Review
This has now happened twice in the last hour. I uploaded an attachment, and after it was uploaded, no keyboard shortcuts or anything else menu-related worked...so I looked up and discovered that all the menus but "Camino" and "Edit" had disappeared.

A re-launch fixed it. Filing as UNCO to ensure it isn't just wackiness with my Mac.
My money's on bug 372571; can you back that out and see (I'm going to bed now)?  
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → Toolbars & Menus
Ever confirmed: true
Keywords: dogfood, regression
QA Contact: form.controls → toolbars
It is the click on the 'browse' button that triggers this. At that moment all menus disappear, except the 'Camino' and 'Edit'. Minefield does the same, but recovers once the file is selected.
Definitely from bug 372571.
Blocks: 372571
Flags: blocking1.9?
Assignee: nobody → joshmoz
Component: Toolbars & Menus → Widget: Cocoa
Flags: blocking1.9? → blocking1.9+
Product: Camino → Core
QA Contact: toolbars → cocoa
Version: unspecified → Trunk
I thought this might happen when I wrote that patch but I couldn't find a test case that actually did it. Found one :)
Priority: -- → P2
Attached patch fix v1.0Splinter Review
Attachment #312831 - Flags: review?(stuart.morgan)
Attachment #312831 - Flags: review?(stuart.morgan) → review+
Attachment #312831 - Flags: superreview?(vladimir)
Duplicate of this bug: 426448
Attachment #312831 - Flags: superreview?(vladimir) → superreview?(roc)
Attachment #312831 - Flags: superreview?(roc) → superreview+
landed on trunk
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.