enable nightly updates for mozilla-central

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 1 obsolete attachment)

Created attachment 312767 [details] [diff] [review]
enable snippet generation for mozilla-central

We should probably give actionmonkey updates at some point too, but that will require AUS2 changes to support multiple branches at the same milestone.

This first patch just enables snippet generation on the nightly builders. I'd like to inspect snippets by hand before we start pushing them. If they look OK then we'll start sending them over to aus2-staging.
Attachment #312767 - Flags: review?(nrthomas)
Comment on attachment 312767 [details] [diff] [review]
enable snippet generation for mozilla-central

>--- a/mozilla2/master.cfg	Fri Mar 28 10:35:04 2008 -0400
>+++ b/mozilla2/master.cfg	Mon Mar 31 11:31:21 2008 -0700
...
>+BRANCHES['mozilla-central']['platforms']['linux']['update_platform'] = 'Linux_x86-gcc4'
>+BRANCHES['mozilla-central']['platforms']['win32']['update_platform'] = 'WINNT_x86-msvc'
>+BRANCHES['mozilla-central']['platforms']['macosx']['update_platform'] = 'Darwin_Universal-gcc4'

This patch looks fine to me overall. Ben says this section is an accidental leftover from another patch and should be ignored. FTR, this sort of change should get run by bsmedberg. IIRC, this string is something to do with the ABI the app declares. Maybe Moz2 is a good time to make this change.
Attachment #312767 - Flags: review?(nrthomas) → review+
I'm pretty sure those 'gcc4' bits need to stay at 'gcc3', since that's the ABI, not the compiler version.

Comment 3

11 years ago
Yes quite, the ABI is still gcc3, even if we're using a gcc 4.x compiler.
Created attachment 312781 [details] [diff] [review]
[checked in] patch as landed (remove update_platform)

update_platform is removed here, but thanks for the info about it using ABI version -- I'll remember that.

changeset:   15:8cef101b0e60
tag:         tip
user:        Ben Hearsum <bhearsum@mozilla.com>
date:        Mon Mar 31 12:54:05 2008 -0700
files:       mozilla2/linux/mozconfig mozilla2/macosx/mozconfig mozilla2/master.cfg mozilla2/win32/mozconfig
Assignee: nobody → bhearsum
Attachment #312767 - Attachment is obsolete: true
Status: NEW → ASSIGNED
I've updated moz2-master and will be triggering nightlies for mozilla-central to get some snippets generated.
Well, enabling this blew out pretty much everything. I'm pretty sure I've got it fixed now..patches coming soon.
(Assignee)

Updated

11 years ago
Depends on: 426443
Looks like these machines are all back up now, sorry for the outage :(.
Created attachment 313029 [details]
complete snippet from linux mozilla-central

Here's an update snippet generated on the linux slave for mozilla-central. The mar does not exist on FTP yet, that will be fixed with bug 426443.

Nick/Rob, can one of you have a look at this? It looks fine to me but more eyes won't hurt.
(In reply to comment #8)
> Created an attachment (id=313029) [details]
> complete snippet from linux mozilla-central
>
> Nick/Rob, can one of you have a look at this? It looks fine to me but more eyes
> won't hurt.

Yes, this looks just like a complete.txt I found on prometheus.

I guess that the nightly scripts on there need to support a new branch, Nick would probably know more about this than I.. maybe that is for a separate bug though. 

Yeah, Nick showed me an AUS config file I had to patch. I'll be doing that shortly. Thanks for looking at that!
Looks good to me too.
Created attachment 313372 [details] [diff] [review]
[checked in] enable update snippet generation + pushing of moz2 snippets

We can't enable this until MozillaStageUpload supports uploading complete mars (bug 426443)
Attachment #313372 - Flags: review?(robert)
Created attachment 313374 [details] [diff] [review]
[checked in] teach aus2 how to deal with mozilla2 snippets

Mike, we'd like to enable Mozilla2 updates soon - I was told this was the only change needed on the AUS side to do so.
Attachment #313374 - Flags: review?(morgamic)
Attachment #313372 - Flags: review?(robert) → review+
Comment on attachment 313374 [details] [diff] [review]
[checked in] teach aus2 how to deal with mozilla2 snippets

Do you have access to check this in?
Attachment #313374 - Flags: review?(morgamic) → review+
I'm allowed to check-in to webtools/, I guess I need to file an IT bug to get it pushed, though?
Comment on attachment 313374 [details] [diff] [review]
[checked in] teach aus2 how to deal with mozilla2 snippets

Checking in xml/inc/config-dist.php;
/cvsroot/mozilla/webtools/aus/xml/inc/config-dist.php,v  <--  config-dist.php
new revision: 1.26; previous revision: 1.25
done
Attachment #313374 - Attachment description: teach aus2 how to deal with mozilla2 snippets → [checked in] teach aus2 how to deal with mozilla2 snippets
(Assignee)

Updated

11 years ago
Priority: -- → P3
Whiteboard: blocked on dependent bug
(Assignee)

Updated

11 years ago
Attachment #313029 - Attachment is patch: false
Mike, there's no rush on this but I'm just wondering approx. how long it takes to land changes on the aus servers. The earliest I'm even thinking about doing this is Monday - but like I said, no rush.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Not sure how this got resolved fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: blocked on dependent bug
(Assignee)

Updated

11 years ago
Status: REOPENED → ASSIGNED
Comment on attachment 313372 [details] [diff] [review]
[checked in] enable update snippet generation + pushing of moz2 snippets

changeset:   20:32e3288d092b
tag:         tip
user:        Ben Hearsum <bhearsum@mozilla.com>
date:        Mon Apr 07 11:53:46 2008 -0400
files:       mozilla2/master.cfg


I commented out the pushing for now. Once the AUS patch makes its way to aus2.m.o we can uncomment them.
Attachment #313372 - Attachment description: enable update snippet generation + pushing of moz2 snippets → [checked in] enable update snippet generation + pushing of moz2 snippets
(Assignee)

Updated

11 years ago
Whiteboard: [waiting on aus2.m.o changes]
Update - will push the config change on Tuesday -- bug 428554.
(Assignee)

Updated

11 years ago
Depends on: 428554
After discussing with nthomas and bsmedberg on IRC we decided to start uploading mozilla-central snippets. I triggered a nightly on OSX - we should have a snippet uploaded in an hour or so. If that goes OK we'll leave it on for tonight and hopefully we'll have updates from now on :).
Whiteboard: [waiting on aus2.m.o changes]
Created attachment 316060 [details] [diff] [review]
[checked in] silly fix

I made a dumb mistake in my last patch - I forgot to run AUS2_FULL_UPLOAD_DIR through WithProperties in the upload step. It tried to upload to /opt/aus2/.../%(buildid)s/... - which is obviously wrong. This is the fix for it.

I pushed the snippet by hand so we don't have to wait on a new build to test this. Hopefully we'll see a partial uploaded soon!
Attachment #316060 - Flags: review?
Created attachment 316212 [details] [diff] [review]
[checked in] use the full path to the complete mar, so the nightly update script doesn't clubber everything
Attachment #316212 - Flags: review?(nrthomas)
Comment on attachment 316212 [details] [diff] [review]
[checked in] use the full path to the complete mar, so the nightly update script doesn't clubber everything

looks good, r+.

I'll fix the files up on stage for ya.
Attachment #316212 - Flags: review?(nrthomas) → review+
Comment on attachment 316212 [details] [diff] [review]
[checked in] use the full path to the complete mar, so the nightly update script doesn't clubber everything

Checking in steps/updates.py;
/cvsroot/mozilla/tools/buildbotcustom/steps/updates.py,v  <--  updates.py
new revision: 1.2; previous revision: 1.1
done
Attachment #316212 - Attachment description: use the full path to the complete mar, so the nightly update script doesn't clubber everything → [checked in] use the full path to the complete mar, so the nightly update script doesn't clubber everything
Alright, I've reconfig'ed the master and kicked a mac nightly - *fingers crossed*.
Created attachment 316220 [details] [diff] [review]
[checked in] use 'nightly' as the update channel
Attachment #316220 - Flags: review?(benjamin)

Updated

11 years ago
Attachment #316220 - Flags: review?(benjamin) → review+
Comment on attachment 316220 [details] [diff] [review]
[checked in] use 'nightly' as the update channel

changeset: 27:590f9dc4a3ec
Attachment #316220 - Attachment description: use 'nightly' as the update channel → [checked in] use 'nightly' as the update channel
Alright, this appears to be working now. nightly/2008-04-17-02 got clubbered, but I believe that's because its' complete snippet did not contain the full path (nightly/2008/04/2008-04-17-02). I expect the next build to work 100% fine.

I *did* manage to get an update for my 2008041702 mozilla-central build, but I had to manually change the update channel in defaults/pref/channel-prefs.js. The update to mozconfig (attachment 316220 [details] [diff] [review]) should remove the need to do this when updating builds generated after it was landed.

I'll keep this open until I verify no clubbering.

(This bug has morphed a bit, updating the summary to be more accurate)
Summary: enable update snippet generation for mozilla-central → enable nightly updates for mozilla-central
This are working fine now: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2008-04-17-06-mozilla-central/

I had to hardcode the channel still, but I've confirmed that it's set correctly in the latest build.

I haven't tested Win32 or Linux but I'll check out all of the nightlies in the morning.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Attachment #316060 - Flags: review? → review?(rcampbell)
Comment on attachment 316060 [details] [diff] [review]
[checked in] silly fix

silly WithProperties.
Attachment #316060 - Flags: review?(rcampbell) → review+
Alright, win32 and linux got updates just fine. Yay :)
Comment on attachment 316060 [details] [diff] [review]
[checked in] silly fix

changeset:   29:8e360f18cb32
tag:         tip
user:        Ben Hearsum <bhearsum@mozilla.com>
date:        Fri Apr 18 08:16:19 2008 -0400
files:       mozilla2/master.cfg
Attachment #316060 - Attachment description: silly fix → [checked in] silly fix
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.