When posting a reply to a discussion board in WebCT 4.1, the browser crashes.

RESOLVED DUPLICATE of bug 425576

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 425576
10 years ago
10 years ago

People

(Reporter: Brian, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Using Webct 4.1 through firefox 2.0.0.13, when you post a reply to a discussion post or an mail message the browser will crash after to post has been submitted.  The post seems to be saved on the server.

Reproducible: Always

Steps to Reproduce:
1. Log into WebCT
2. Open a course with a discussion board.
3. Open a post.
4. Click reply.
5. Type something in the message box.
6. Click Post.
7.  The popup window will close and then the browser will crash.
Actual Results:  
Browser crashes.

Expected Results:  
Page should refresh and show you the new post.

Have reproduced on both Windows Xp and Windows Vista.
(Reporter)

Comment 1

10 years ago
Link to someone else with same issue.
http://www.ltrc.mcmaster.ca/webct/announcements/index.shtml#mar27_08


Version: unspecified → 2.0 Branch
Do you get the crash also in the safemode ?
- http://kb.mozillazine.org/Safe_Mode

If yes: Please provide a Talkback id from that crash :
- http://kb.mozillazine.org/Talkback
Keywords: crash
(Reporter)

Comment 3

10 years ago
TB43373889Q Talkback ID

Yes it also crashes in Safemode.

Thanks
js_MarkGCThing  [mozilla/js/src/jsgc.c, line 2447]
JS_GC  [mozilla/js/src/jsapi.c, line 1879]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16fd7 (0x7c816fd7)
could be related to bug 425576
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: 2.0 Branch → 1.8 Branch
Duplicate of this bug: 426816

Comment 7

10 years ago
Crash also occurs w/ posting in WebCT CE 4 Mail tool. Prob. same mechanism invoked on post to close popup compose window. Crash does not occur on Mac OS X or Linux FF 2.0.0.13.

Comment 8

10 years ago
I believe the issue is triggered in the following manner.

1 - pop up window opens
2 - pop up calls a CGI action
3 - CGI action sends back a close()

I don't have access to the CGI source, but here's what I was able to snag traffic-wise.  The CGI sends back:

Content-Type: text/html; charset=utf-8

16a
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">
<html dir="ltr">
<head>
<link rel="STYLESHEET" href="/web-ct/en8/style/styles_all4x.css" type="text/cs
s">
<style type="text/css">
<!--
@import "/web-ct/en8/style/styles_nonn4.css";
A.action IMG { vertical-align:0% !important; }
-->
</style>
<title>Discussions</title>
<script>
window.close()
</script>

Comment 9

10 years ago
Created attachment 313818 [details]
show compose has the pop up to open compose.html

Comment 10

10 years ago
Created attachment 313819 [details]
compose.html has the post button on it w/c calls the cgi

Comment 11

10 years ago
Created attachment 313820 [details]
close_compose is a PERL CGI that spits back what I saw traffic wise

Comment 12

10 years ago
In my close_compose, I've stripped out link and stylesheet lines as that the same outcome was still generated.

Unhandled exception at 0x600f0290 in firefox.exe: 0xC0000005: Access violation reading location ...

Comment 13

10 years ago
test case. put show_compose.html and compose.html on a server, put close_compose in the server's cgi-bin.  call show_compose.html from the ff 2.0.0.13 browser, click on the 'Compose message' link.  in the compose.html pop up, click on the post.

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

10 years ago
May have been resolved with the release of FF 2.0.0.14.  So far testing has not crashed.
we created 2.0.0.14 because of bug 425576 (see comment #5).
If this works for everynone else with 2.0.0.14 i will mark this as dupe of bug 425576

Comment 16

10 years ago
The similarity to bug 425576 is that its a crash in the js3250.dll.  However, the excite.jp case also crashed on FF 2.0.0.13 on OS X, which we have not seen.  Perhaps the fix implement for the excite.jp case fixed a broader issue, and we were a subset?  Anyways, I'm happy FF 2.0.0.14 was released!
You can't compare crashes based on the crashing ddl like "js3250.dll", but I can compare based in the stack trace.

I'm sure that that this is the same garbage collector crash, marking as dupe
 
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425576
You need to log in before you can comment on or make changes to this bug.