Closed Bug 426438 Opened 12 years ago Closed 12 years ago

Printing results in garbled text output (FF3b4, HP LJ 2200dn, PCL6)

Categories

(Core :: Printing: Output, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 454532

People

(Reporter: dan, Unassigned)

References

()

Details

(Keywords: qawanted, regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I am using FF3b4 with a HP Laserjet 2200dn with PCL6 drivers on WinXP Pro SP2. 
Printing worked fine with FF 2.0.0.13 a few minutes before I installed FF 3b4. 
Certain web sites result in garbled output being sent to the printer. Page layout is relatively consistent, but text (not graphics) is garbled -- text is not readable with various unicode characters substituted for real text. 
Tried this at www.hp.com (main page) and several USPS.com pages. In print preview everything looks fine. Tried this with several different page scaling settings, including 100%.
Interestingly, I don't have this problem at www.mozilla.com. Main page at www.mozilla.com won't print with the CSS layout at all -- even in print preview, it looks like I'm viewing it in a browser that doesn't support CSS. In browser view looks fine. 

Reproducible: Always

Steps to Reproduce:
1. Go to www.hp.com
2. Print


Expected Results:  
Printed page normally without garbled text. Worked fine in 2.0.0.13.

Active Add-ons: Greasemonkey 0.7.20080121.0, IE View 1.3.7, DownThemAll! 1.0, Better Gmail 2
I don't see this problem on the HP website with the latest Firefox 3 nightly.  But I still see garbled text on other sites (you might want to take a look at bug 432071).  Do you still see this problem on the HP website?
I'm using a HP Laserjet 8100n and am having the same problem when printing.
(In reply to comment #2)
> I'm using a HP Laserjet 8100n and am having the same problem when printing.
> 

What version of Firefox are you using?  Could you post your user-agent string?  (Help > About Mozilla Firefox > copy the text you see at the bottom)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
(In reply to comment #1)
> I don't see this problem on the HP website with the latest Firefox 3 nightly. 
> But I still see garbled text on other sites (you might want to take a look at
> bug 432071).  Do you still see this problem on the HP website?

Yes. Still same problem on HP website. Other sites have this problem too. 

I upgraded to FF 3 RC1 and still same problem.

My 2 other PCs (Linux with FF 3 RC1) printing to same printer on same local network do not have this problem.
I am experiencing the same symptoms.  Initially I attempted printing directions from google maps without success then attempted a multitude of other sites and on other computers that have firefox 3 with no success.

Firefox Version:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

OS: Windows XP Professional Version 2002 Service Pack 2
Machine: Dell Optiplex GX745, Intel Core 2 CPU, 6400 @ 2.13GHz, 2.13GHz, 1.99GB of RAM
Printer:SHARP AR M350N

Let me know if I can provide any further information that may be useful.

I'm experiencing the same thing. In my case, when I was printing my Citibank statements (citicards.com). Some of the text is readable, but at the bottom of my statements I get gibberish text.

The gibberish looks like this: http://www.solo-technology.com/blog/2008/05/20/firefox-3-rc1-printing-garbage/
(apparently this guy is experiencing the same thing)

I'm using the stable version of Firefox 3, downloaded from spreadfirefox.com on Download Day.
My setup: Windows XP SP3, Intel Pentium M 760, 2 GB RAM, HP Deskjet 6540

Component: General → Printing
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → 1.9.0 Branch
Keywords: qawanted
I am having the same problem.

Firefox Version: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

OS: Windows 2000 Professional Service Pack 4
Machine: Dell Precision 330
Printer: Minolta Di520
I observed this issue with Google Maps.  When printing to an HP LaserJet 5000 all text on the page is garbled; the direction words, street names, and addresses are garbled when printing to a Xerox Phaser.  I had Firefox 2 on this machine before installing the Firefox 3 release on Download Day.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

If it helps, this is on my work computer printing to network printers.  I haven't yet tested FF3 printing on my home setup.
I noticed the same problem here while printing pages from my own Bugzilla installation (2.17.4). Printing worked fine with FF 2, I get garbled text with FF 3.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Printer is Imagistics im3510 PCL6.

FF serif font set to Times New Roman, 16 pt.

If I change font to Trebuchet, I get good print.

If I print to PDF using PDF995 I get good print, even using Times New Roman font.
Using the "Zimbra (tm)" webclient to produce a printout encounters this problem every time. I have spent quite some time moving local users from IE to FF due to speed issues in javascript loading in IE. It now looks like I'll need to tell them to switch back to using IE inorder to print some web documents. 
Hi Folks,
This is John Holder with Zimbra/Yahoo!

I can confirm that this is an issue with the TTF.
(In reply to comment #10)
> FF serif font set to Times New Roman, 16 pt.
> 
> If I change font to Trebuchet, I get good print.
> 

Hmm, maybe font substitution is what is triggering this bug?  Many laser printers have internally-installed fonts like Courier, Helvetica, Times, et al. and will substitute in these fonts when printing Courier New, Arial, TNR, et al., whereas fonts like Trebuchet are not substituted.
Keywords: regression
Tried it with 4 different printers.  It always happens with PCL5/6 drivers and does not happen with PS drivers.  This completely breaks printing from Zimbra unless the user happens to have a printer with PS drivers (none of my inkjets do).
we have the problem also with postscript printers and when print to file as pdf.
with linux and windows.....
I'm wondering if this problem is the same as bug 396315 and bug 425336.
When printing my my bank statements, and the bank confirmed they support Mozilla Firefox u can read it fine on screen, but will not print out the personal statement information correctly, it is a garbled mess, but the page layout is correct.  It will print the bank form to reconcile normally which has no personal info on it. I went into Internet Explorer and logged in and it printed just fine?
I am the OP. I can confirm that this is a problem with the PCL print driver on Windows. I used PS print driver from linux & Mac and printing is fine. I switched to PS print driver on the Windows machine that had the original problem and it now prints correctly.
To add to my previous information... if you view the web page in Print Preview and Print from there, it prints normally.  The exact same page printed straight from the browser window will print the garbled text.

(In reply to comment #9)
> I observed this issue with Google Maps.  When printing to an HP LaserJet 5000
> all text on the page is garbled; the direction words, street names, and
> addresses are garbled when printing to a Xerox Phaser.  I had Firefox 2 on this
> machine before installing the Firefox 3 release on Download Day.
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906
> Firefox/3.0
> 
> If it helps, this is on my work computer printing to network printers.  I
> haven't yet tested FF3 printing on my home setup.
> 

Also I have the same problem with Firefox 3 (German version) and PDFs prints, I create with Adobe PDF Writer 4.05 from Fireefox 3.0. The result is a completely garbled document, just the graphics are fine (Unfortulately, it is not possible to upload a sample file here to show the bug). Chanding Character Codes is not helping at all. PDF prints out of IE6 or earlier FF versions are fine.

Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9) Gecko/2008052906 Firefox/3.0
WIN 2000 SP4
I too have been having the garbled text when printing. I am using a Kyocera printer and just went into the properties for that printer and disabled the device fonts and now the problem is gone.

Hope this helps...

Be blessed,
David
We have a internal site and print financial reports. We had FF 2.0.14 before and everything was printing fine. I installed FF 3.0 and suddenly getting garbage characters on top portion of the page. Only portion of the page is garbage text and rest is ok. other posts suggested checking off 'Allow page to use own fonts...' and selecting a specific font and size for entire page. This will not work for us. Our reports have to be exactly like before. Now seem firefox is forcing everyone to upgrade to 3.0. I now have to go around the office and uninstall 3.0 and install 2.0.14. This is a real pain. I wonder if you guys actually tested the print feature on actual realistic setups. Please fix this very annoying problem that seem to have been around forever.
I was having the same issue, tried all the resolutions that i could find but nothing worked. Finally changing the default font to "Trebuchet MS" fixed the problem and now i can print normally.

Firefox/3.0
WIN 2000 SP4
I'm trying to find out if Microsoft's KB948046* would fix my problems, but the only website where I ran into problems (support.mozilla.com) had changed its design and fonts, and I can no longer reproduce the problem there.

For those of you who are reporting this problem, can you please provide a URL of a website (or better yet, attach a sample HTML file) that exhibits print corruption?

(*Microsoft's KB948046 update fixes a print corruption problem that occurs when the Arial font installed by Microsoft's EU font update used in conjunction with a PCL printer; it just so happens that I was using a PCL printer with the Arial from the EU font update when I encountered the corruption--though strangely enough, I didn't see the problem on other websites that used Arial, so this may be an unrelated issue, or there may be other conditions needed to trigger.)
Here is the actual output from the HTML file of attachment #335875 [details].
I just upgraded to Firefox 3.0.1 and when I print my service issues from our hospital's software vendor, Meditech.com, the text is garbled characters.  I had no problem with my previous version of Firefox.
I tried changing the font to Trebuchet MS and that does not fix the problem

Looking at the page in Print Preview first (comment 19) DOES fix the problem

Firefox 3.0.1
HP Laserjet 4+
I am curious, does the problem still occur if you update to the latest printer drivers for your printer?  And some people are not posting which OS they are on, so while the bug says Windows XP, someone is saying they have the issue on Windows 2000 (and thus I'm asking people to start post their OS too):
<http://getsatisfaction.com/mozilla/topics/firefox_printing_rubbish>

comment 24 suggests installing this microsoft update as well:
<http://support.microsoft.com/kb/948046>
I have the latest printer drivers installed...
Windows 2000 SP3 is my OS, but it also failed on my Vista laptop

Again, if you display the page in Print Preview first, it ALWAYS works
For me, printing to Adobe PDFWriter always give garbled characters. Printing to Adobe Distiller works fine.
This may possibly due to font substitution of the Windows bitmap fonts that are substituted with printer fonts when printed. See http://bugzilla.zimbra.com/show_bug.cgi?id=29379

I would also check the advance print options and ensure the TrueType Font option is set to "Download as Softfont" and not "Substitute with Device font".
Just updated to FF 3.0.2. When I print the following page I still get black blocks for the Courier Type 1 font:

https://bugzilla.mozilla.org/attachment.cgi?id=281051
Everything worked fine with FF 2.x  I started getting gibberish with 3.0.  Problem is still there in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

Printer is: SHARP AR-M237 PCL5e

No other application has this bug.  Nearly all websites produce gibberish text. Most annoying is maps.google.com Tried the following workarounds: 
Print Preview First: Same bug
Print to PDF: works great
Changing fonts: Same bug
Printing at 100% scaling: Same bug
Change Default Font from TNR to Trebuchet MS: Same bug
Change to Trebuchet AND deselect "pages choose their own fonts": Works! 
Reinstalling print drivers: havent' tried yet
Messing with my Print Options (Advanced): Same bug
Switching to FF 2.0 or IE: Works great
What changed from ff 2.0 to ff 3.0 as far as the printing function goes? Does anybody really know? Also noticed that all my single spaces between text is doubled in the browser view. This only happens when using ms sans serif font with css. We are still using 2.0.14. Here is a link to all of FF older versions. 

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/
Looks like this is a more specific version of bug 454532.  Possibly a dupe; I'm just marking dependency for now.

I'm also changing branch to "Trunk" -- I'm assuming this is still broken in the nightly builds, until someone says it's fixed there. (Comment 1 implies that it may have been fixed for one particular website but not for others, so I don't count that as 'fixed'.)
Depends on: 454532
Version: 1.9.0 Branch → Trunk
I just tested one marked text with FF2, FF3 and IE6 on monster.de on my only printer Epson EPL 5800. Result: garbage by FF3.

OS: Windows XP64
PDF: Foxit Reader
Printer: Epson EPL 5800, PS 3, new Driver installed (epson319963eu)
FF2: german
FF3: german, both downloaded from mozilla site.
font: Times new roman
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454532
We were using this old microsoft font "MS Sans Serif" in our styles. Once we removed this there was no more garbled text.
You need to log in before you can comment on or make changes to this bug.