Last Comment Bug 426450 - PKIX_PL_HashTable_Remove leaks hashtable key object
: PKIX_PL_HashTable_Remove leaks hashtable key object
Status: RESOLVED FIXED
PKIX NSS312B2
:
Product: NSS
Classification: Components
Component: Libraries (show other bugs)
: 3.12
: All All
: P1 normal (vote)
: 3.12
Assigned To: Alexei Volkov
:
Mentors:
: 426484 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 17:04 PDT by Alexei Volkov
Modified: 2008-04-02 00:48 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch v1 (4.89 KB, patch)
2008-04-01 17:04 PDT, Alexei Volkov
nelson: review+
Details | Diff | Splinter Review

Description Alexei Volkov 2008-04-01 17:04:40 PDT
Created attachment 313001 [details] [diff] [review]
Patch v1

pkix_pl_PrimHashTable_Remove returns only a "value" object and so the "key" object is lost. To fix, need to modify pkix_pl_PrimHashTable_Remove argument list to return an original key and destroy it as well at PKIX_PL_HashTable_Remove level.

See attached patch.
Comment 1 Nelson Bolyard (seldom reads bugmail) 2008-04-01 20:42:22 PDT
Comment on attachment 313001 [details] [diff] [review]
Patch v1

r=nelson
Comment 2 Alexei Volkov 2008-04-01 22:08:31 PDT
patch is committed.
Comment 3 Slavomir Katuscak 2008-04-02 00:48:51 PDT
*** Bug 426484 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.